Can't add new (or old) zigbee devices

So I thought it was an issue with a zigbee device that I accidentally reset. Tried to re-add another zigbee device, and it also failed, both by explicitly choosing the device, and by doing “scan for available devices”.

On the web app, there is literally no option anywhere to add a device. The plus sign (obvious design language for add device) only shows MOVE device from other room, or add room, no option to add device.

All the zwave devices stayed connected and are controllable.

The hub blinks green, the devices blink the appropriate colors, but no pairing ever happens.

This is 2 separate problems:

  1. Can’t pair (zigbee) devices. Not going to disconnect zwave device and risk more failures.

  2. Can’t even ATTEMPT to add/pair devices from the web app

v2 hub, android app or web app

The web app (assuming you’re referring to my.smartthings.com )has never allowed adding devices.

In the mobile app, if you tap the upper left menu (your location name), how many locations does it show?

Just 1 location in mobile app.

Do you have any zigbee devices currently connected to your hub? If the answer is no, check if zigbee shows as functional in IDE.

1 Like

Could be a failure of the Zigbee radio itself, but it could also be that you’ve hit one of the maximums. There is some documentation on this, but it’s very deep in the developer information and it’s hard to find.

So… how many total devices do you have (counting all protocols, including virtual devices)? There is a limit of 200, and after that you aren’t allowed to add more. :thinking:

How many Zigbee devices do you have which are not repeaters? This includes all sengled brand devices as well as most battery powered devices. It does not include Zigbee devices connected to a Hue bridge.

FAQ: 32 Zigbee direct connection device limit?

Another possibility: if your v2 hub is near a wifi AP that could be causing interference.

2 Likes

Where do I see whether zigbee is “functional” in IDE?

under My Hubs, there is a section for zigbee

4, 2 zwave switches, 2 zigbee sensors

  1. They both used to be connected and now don’t connect.
1 Like

This is true. But it’s always been there. How can I check this?

It’s functional on IDE.

If you only have 12 devices total, you don’t need to worry about the maximums for now, so that’s not it. :thinking:

have you tried bringing the devices near the hub to see if they pair?

Yes. I tried ~5’ and ~5". Neither worked.

Hub says status: INACTIVE on IDE, but I’m guessing that’s normal when I’m not sending commands and it’s not receiving sensor data

There could be two types of interference from wifi:

  • hub is to close to a wifi AP
  • channel overlap between zigbee and wifi 2.4

for the first, you can try moving it further away (10 feet/3meters) from the wifi device
for the second, change the zigbee channel the hub is using

@jdroberts can talk about that.I am sure he has a faq page :slight_smile:

yep…

or I could just be leading you on the wrong track in resolving the issue

worth checking… did you properly reset the zigbee devices? brand/model for the ones you are trying to add?

1 Like

Switching to less-trafficked channel.

Yes. Lights flash showing reset / ready to pair. Different brands/models. Both were connected fine for months until about 7 days ago.

Actually, IDE has change channel option for zigbee but it’s not applying my change. Is this a known problem? I rebooted after waiting several minutes, but it’s back on old channel.

1 Like

There are platform issues today, so I don’t know if anything can be considered reliable right at the moment.

1 Like

FW version says 000.043.00004. Would this have been updated recently? That might explain the change in function.