Can't add any new switches says "something went wrong, try again later"

I can’t add my new switches because this error keeps popping up. they are GE but I have tried every brand and they all pop the same error in the app. I have restarted phone and the hub but still happening. I can still control existing items and can even add things other than switches but for some reason it errors out on the switches. Getting pretty annoying! Anyone else?

What is the model of the GE switches?

Did you try Scan Nearby?

also… check in the Devices section under No Room Assigned or All Devices to see if the device(s) may have added in an earlier attempt.

if no devices are found… run z-wave repair if they are z-wave to check for any errors

So It looks like its something do with the Android app. My wife has an Iphone and I decided to try it on her phone. Worked right away. Very weird. Hoping this was just a weird thing or gets patched by the next time I need to add something else! I had tried scan nearby and also tried adding via QR code and manually and it always did the same thing.