Cannot reset Fibaro Relay FGS 212


For the past many hours have been moving everything to a V3 hub. The hub itself it great - the migtration process is horribly tedious.

Most devices i’ve been able to work though - but am stuck with the Fibaro Relayt, which i use in my garage to switch lights.

Have tried everything i can think of

  • Moved hub to be next to the relay
  • Switched off mains first, whatever that would do, and then switched on again before resetting
  • Tried exlusion mode, with combinations of pressing the B button 3 times, and holding down for 3 times
  • Tried holding down the internal B button for 3 seconds (and longer!) as per the manual
  • Tried re adding through both the classic and the newer ST app

… but nothing will see them reconnect. I have 3 in total across the house, so loath to write off the money. Must be something i’m doing wrong…

The only think I haven’t tried is disconnecting all the wires other than the mains input - which you can infer from the manual, but it’s not explicit. I’m reluctant to do that and start mucking about too much if there is an easier way to do this. It’s also a rare 32 c day in the UK today, and both the garage and gym where these are located must be over 40 degrees at the moment, so not much fun fiddling with them.

Any help much appreciated.

arrggh - i think i’ve worked it out. You need to hold down the B button whilst reconnecting the power.

Unless i’m missing something - that’s awful design. It’s either a two man (or man and wife, as will have to be when i try tomorrow) to have one hold down the button whilst the other flips the fuse breaker… or just encourages you to try and reconnect the wire to the mains input whilst it’s live. Which isn’t a bad way to be Horribly Killed…

Not an electrical engineer by aaannny means, but everything else has failed - so this must be it…

Nope- that’s not it. Any help appreciated - this is driving me insane!

Maybe you can’t delete it because it’s already included as a ghost device, run a Z-Wave repair and have a look.

In the end this was the fix - i tried it before, but stupidly didn’t notice the socket powering the hub was on the same fuse breaker, so of course exclusion mode didn’t work.

After getting successful exlusion messages, i still couldn’t add for an hour or so - despite all button presses. Then after a few network repairs, i checked again - and both relays popped up when i added devices, without me having to press anything.

One more to go - but it’s in the convervatory, and the temp sensor in there measured 49 degrees peak today - one for cooler weather…

1 Like

@keithmizen I’m in the same boat as you, I’m starting to think these Fibaro Relays, FGS 212, just aren’t compatible with the new v3 hub. I can’t get it to Include. Tried both Classic and new app. The v2 hub is fine, it connects in seconds, but this v3 hub is proving impossible, I’m thinking of sending the v3 hub back.
Did you get all your FGS 212’s included in the end?