Cannot force remove GoControl FS20Z-1 isolated contact


(RT) #1

I have the GoControl Isolated Contact FS20Z-1 and it acts flaky. It sometimes gets out of sync with ST. Like it says it is ON when it is really off or vice-versa. Its happened a few times. I have not been able to get any response or support from their technical support. Therefore I want to permanently delete the device and replace it with a MEMOlite.

The challenge I have is that I cannot get it to remove itself. I go through the ST steps to remove it and then I follow the sequence that the GoControl instructions say to do to remove it, but nothing happens. I’ve tried the button sequence dozens of times and in all sorts of variations but nothing happens. ST gives me a force remove option which I try but it does nothing. So I cannot delete the device out of ST. I don’t have any smart apps or rules based around it and don’t get any error messages when trying to delete it.

Can someone please elaborate on how I can delete the device from ST? Is it 100% necessary to get the GoControl device itself to detach itself, or is there a way to tell ST to entirely forget the device and no longer have it show up.

Also - I would really like to try resetting GoControl back by deleteing it and then readding it and see if that helps, but I can’t because of the reasons above. The instruction say this: “To remove a node: Tap the button 3 times, then press and hold (Ex. tap, tap, tap, hold)”. I’ve tried this at least 40-50 times! Nothing happens on the GoControl itself (no change of the LED light) and nothing happens in ST. Can someone perhaps explain step by step how I should go about trying to fix this, especially if you are familiar with this control?

One possible cause for the issue - The instructions say that you cannot bench test the device - that it must be added to the network from its permanent location. I did not see what when first setting it up, and indeed I did bench test it. I wonder if that is the reason for its odd behavior where it gets out of sync an ST says its on when its off or vice versa. Anyway I am trying to delete it and start over, but can’t remove it as explained above. Hopefully someone can help - thanks!


#2

What happens when you run the zwave repair utility? Do you get any error messages for the device? (That should resolve any issues from the bench pairing.)


#3

The instructions aren’t quite clear because they aren’t telling you what you have to do with the controller (the smartthings hub) because that will vary from controller to controller. You’re probably running into a problem because the exclude process (what they are calling “remove”) requires action by both the controller and the device, and you have to do them in the right order and within 15 seconds of each other. . Just pressing the button on the device won’t do anything unless you have also issued an exclude from the controller.

My suggestion would be:

One) run the zwave repair as described in the previous post. Note any error messages and keep those.

Two) remove the device from any smart apps or routines that are using it

Three) exclude the device from the network. Don’t delete it from the IDE. Exclude it. Use “remove” if it did show up correctly on the Z wave repair. Otherwise, use a general exclusion if it didn’t show up on the Z wave repair. This will involve first issuing a command from the hub and then doing the button tap process on the device. Note that you must start the button tap within about 15 seconds of issuing the controller command, so be ready.

  1. If you complete the exclusion but it still shows up in the IDE, you will have to force delete it at that point. However, there are a few known bugs where it won’t let you delete, in particular if the device was ever included in an IFTTT recipe. For those, you will have to ask support@smartthings.com to remove it.

(Pizzinini) #4

Yeah… This relay is quite tricky to unpair. I remember spending more then 30 min to remove it when migrating from hub v1 to V2. I followed all the steps but it just never worked. Remember that you do need to press that little button on the relay pretty fast three times before you hold it. It is a bit of a pain but eventually it will work. Good luck!

I never had any other issues with the device for over 2 years though… maybe a z-wave network repair will help fix it and you actually dont have to replace it?


(RT) #5

Thanks. I ran the repair and nothing showed up (at all) other than started, finished.

Then I did this:

  • Went to the Device in things. Says it is ON, but it is really OFF (verified at the device itself). If I click the ON it turns to OFF. But when I then click on the device it is lit green and says ON in the big icon. That’s the whole issue here.

  • From the Device page that shows the status with the big green plug I click the Gear icon.

  • From the Replace / Remove buttons I click Remove

  • It asks if I’m sure. I click Remove

  • It says to follow the devices instructions. I use tap, tap, tap, press and hold as the instructions say - all within 5 seconds of clicking Remove.

  • Nothing happens no matter how long I hold the device button (as part of its remove instructions). ST just sits there indefinitely. When I try force remove, nothing happens.

Am I following your instructions correctly? Any other advice? Thanks.


(RT) #6

Thanks pizzinini. Is it tap, tap, tap and hold? Or is it tap, tap, tap, release and tap and hold? Also how quickly do you need to press the tap. Like really fast like 0.25 seconds in between or more like 0.5 seconds or 1 second?


(Pizzinini) #7

tap, tap, tap, tap+hold - really fast, It was more like 1-2 secs total

I do not remember though if the relay had to be on or off at the beginning of the sequence though.


(RT) #8

Thanks pizzinini - Once you get the sequence right, how long do you have to continue to hold the button on the GoControl before ST will recognize that it receives the delete request? I am holding it for a long time - never recognized. I tried dozens of ways - slow taps, fast taps, in between taps, starting with it off, starting with it on. Nothing works. What’s the secret?


#9

Sounds right…at this point I’d see if support@smartthings.com can help. I know it’s frustrating, I wish I had another idea to help.


(Pizzinini) #10

I think I held for about 5 sec before the confirmation message came in the app on the phone. I tried lots of times, too. Very frustrating experience but eventually it worked.

I also remember disconnecting the relay from power for a couple of mins… not sure if that helped but it may be worth a try.


(RT) #11

OK thanks. I have seriously tried over 100 times. Very frustrating and it certainly doesn’t help that technical support was unable to assist when I called last time. I’ll try again and maybe get someone else.


(RT) #12

Guys - I spoke to tech support for the GoControl. They suggested that the distance between my ST hub and GoControl device may be causing the sync issue - and may also be the reason why the Remove function does not work. I’m not sure distance is the issue tho… I do not have any repeaters set up, and the GoControl is in the basement, one floor below where the ST hub is - but is only maybe 25 feet at the most line-of-sight away if not for the separate floor.

So I am going to try a few things. One is that I will put the ST receptacle that came with my ST starter kit at a place where I think acting as a repeater could help. Then I will repair the network and see if that helps. If that doesn’t work I will move the GoControl closer to the hub and see if I can delete it this way.

Thoughts?

A question in the meantime please - when I tell ST to “repair” the network, does it go through and rebuild the mesh network and make use out of devices that can act as a repeater? If not, how do I tell ST to refresh/rebuilt its network after I move things around like the receptacle to give it a chance to be picked up as a repeater?

Thanks!


#13

Zwave repeats only for Z wave, zigbee repeats only for Zigbee. I believe all of the SmartThings – branded devices are ZIgbee, so they won’t help as your relay is a Z wave device.

It can’t hurt to move the go control closer to the hub or, if you have a long cable, move the hub closer to the go control.


#14

Yes, that’s exactly what it does. It contacts each device on the Z wave network and tells it to rebuild its neighbor table ( The list of repeaters that are closest to it) .


(RT) #15

OK, although the issue is not yet resolved I made great progress tonight in understanding what is going on thanks to the help here. First thing I tried tonight was taking my ST outlet and trying to use it as a repeater for Zigbee and did a repair on the ST network. As JD mentions this does not work and it made no difference. I decided to try it because in this post Zigbee Repeater someone specifically listed this device as a repeater for Zigbee. I assume based on JD’s info that the info in that post is not accurate.

Next I moved my GoControl into the room where the ST hub is. All of the sudden the sync problem was fixed. When its off it shows off, when its on it shows on and toggle keeps the state correct in ST. Before I had relocated the GoControl near the hub it was out of sync and I could not correct it.

Next I tried Removing the device from the Z-wave network via ST. I had tried over 100 ties before and it never worked. This time it worked in seconds when I did it form the room where the ST hub is. Also for reference the pattern is tap (release), tap (release), tap and hold (so 3 taps with the last tap held, not 4 taps with the last tap held).

Then lastly I took the GoControl back to its original place and tried adding it back into the network. ST could not find it no matter how long I waited. Then I remembered I had this issue originally, and took it to the room with the ST hub to add it as a device weeks ago when I first set it up. Then when I moved it to the basement it did fine, except for these occasional issues.

Summary: So CLEARLY we can conclude that the issues I have been having are due to limitations to range. That is disappointing because by line-of-sight the GoControl is only 20 feet away. But its in the basement so apparently getting thru to the level above is an issue.

In reading through the threads it seems other people have sought out Zigbee repeaters but did not find anything. If anyone knows of a device I can add to act as a repeater, please let me know.

The other option I have is to return the GoControl and replace it with the MIMOLite, which is Z-Wave based and will serve the same purpose. I prefer the GoControl because it does not need a plug-in transformer, but if I can’t solve the connection issue then the only option may be to go the MIMOLite route.

Thoughts?

Thanks!


#16

Wait, wait, wait!

The GoControl relay is a zwave device. Zwave repeats only for Zwave, Zigbee repeats only for Zigbee.

http://www.nortekcontrol.com/pdf/manuals/FS20Z1_manual.pdf

Why are you asking about Zigbee repeaters? They can’t help with a Zwave device.

As far as Zigbee repeaters, if you do need one, see the following topic. But again, they can’t help with a Zwave device.

The SmartThings hub is a white plastic box that contains five different devices. There is an ethernet connection which is used to connect to your router.
There is a Bluetooth radio which isn’t turned on yet.
There is a zigbee coordinator which talks to your Zigbee devices.
There is a Z wave controller which talks to your zwave devices.

And there is a little tiny processor which figures everything out.

So in your house you actually have two totally separate mesh networks, one for Zigbee and one for Zwave. Devices on one don’t repeat for the other.


(RT) #17

Oh wait, I got confused by your earlier message then… OK so ST talks Z-Wave and Zigbee, got it. And GoControl is a Z-Wave device, got it. And the ST smart AC adapter/plug that comes with the Hub v2 starter pack is also Z-Wave. Therefore I should be able to use the AC adapter as a repeater for Z-Wave, right?

From my experiments earlier tonight we can conclusively say that my issues are due to range/limitations. The AC adapter device that came in the ST kit works perfectly fine in the same room (right next to each other actually less than a foot apart) that the GoControl has issues. So perhaps the reception in the GoControl is weak compared to the AC adapter.

I tried positioning the AC adapter in places that could improve the signal by serving as a repeater and then rebuilding the network. However the GoControl still cannot be picked up by ST. Any other ideas here? Thanks!


#18

I believe that plug is Zigbee, not Zwave. So that was the confusion, in that post I was talking about the plug, not the GoControl device.

Look on the back of the plug, what logos does it have?

The plug that comes in the V2 kit should be Zigbee:


#19

The DragonTech Zwave plus pocket socket is a popular inexpensive Zwave repeater with very good range if you need one:

http://www.zwaveproducts.com/shop/z-wave-lighting/z-wave-plugin-modules/z-wave-plus-plug-in-on-off-switch

Lowes also has a $35 zigbee pocket socket which includes a zwave plus repeater chip. So it can repeat for both Zwave and zigbee. Which is weird, but it works. There’s a community created device handler for it:


(RT) #20

Yes JD you are correct. The ST smart plug I have says Zigbee on it. I totally follow what you are saying now and thanks for the info about the Iris Smart Plug. Looks good.

Question - Clearly the Z-Wave GoControl device is having issues with range/connectivity. Perhaps this is because it is not very good at working over longer distances. With that in mind, do you think there’s a reasonable chance that the Iris Smart Plug - located right next to the GoControl - will have better reception and pick up the ST hub much better, so that it can then be a repeater for the GoControl? Or do you think that if the GoControl has range issues in that spot the Iris is likely to have the same connectivity issues and not be of much use as a repeater in my case?