Cannot add Smart Plug to SmartThings Hub

I have added Samsung Smart Plugs to our home set up before but to now scan the QR code from a new Samsung Smart Plug results in showing a null device which cannot be added. Any idea what has gone wrong here?

Hi @Michael_Johnson

Is it the Smart Outlet that comes with the SmartThings Box?

  • Try rebooting manually your plug and adding your device again. As last thing, update your SmartThings app if you haven’t.

Share with us if worked.

Good evening Erick,

This is not the Smart Outlet but in fact a brand new Samsung Smart Plug.

The following steps may explain my issues…

Simply stuck. Cannot add any further devices. Data needs to re-downloaded again some how.

Any ideas?


Did you ever figure this out? I also have a WiFi Smart Plug and simply cannot get it added to SmartThings. Thanks!

edit: never mind, I figured it out… used my ipad to set it up… iphone just refused to do it.

I had the same problem. Could be something with the iPhone. When I switched to a tablet it worked.