Can you install Webcore without the Classic app?

Several people have reported that once they migrated, or if they never had the classic app, they were not able to install Webcore.

Here’s an example:

Recreate a routine in the new Smartthings

Can anybody confirm one way or another if you can install webcore for the first time if you don’t have the classic app?

you can. the only bug seems to be adding devices to your webcore instance where you end up cancel and discard but the devices that you selected are saved.

start in + Smartapp to add/create a new instance of webcore (Classic app was Markeplace > smartapps > your apps)
menu > smartapps to manage your existing instances of webcore (Classic app was Automation > smartapps)

2 Likes

You can’t. After installing webcore, the first thing it asks for upon launch is the registration code. The instructions to get the code reference opening ST Classic and going to the automations icon at the bottom. There’s no way to link webcore to the new SmartThings without the old one, at least not that I have found.

to get the register code to open the webcore dashboard --> menu > smartapps > your existing instance of webcore > register a browser

I’m not following. Menu > smartapps doesn’t get me to an existing instance of webcore. My smartapps list only contains Sharptools, Smart lighting, and SmartThings Home Monitor. The + sign only lets me add the built in Smartapps, which are a very limited list.

you should see a custom section at the bottom of + Smartapp that would list webcore or any other custom smartapps you have installed. if you are not seeing webcore; you either don’t have it set up properly or your data is not synced between the classic and new app.

It does work in the new app… others are using it

I don’t have Classic installed any more. After the migration I removed it because I thought everything was working fine. And I didn’t have webcore installed prior to the migration. Hence, I can’t install webcore now.

have you even tried to install it? you don’t need the classic app to install webcore

Yes, I have webcore loaded on my Android phone now. When I launch it, it asks for a registration code.

that is only one component of webcore… the app that runs on a device to manage it. You will need to install the smartapp (actually 4 of them) in ST before you can use that app.

start at these links to get started:

when you see the installation instructions, substitute the locations I posted in the second post of this thread for the classic ones in ()

1 Like

Ah, didn’t know I had to involve the IDE. Thanks, will give it a shot.

1 Like

OK, I give up. I followed the instructions, both manually and with Github integration. I can get the Smartapps loaded in the IDE, but the NEW Smartthings app does not see webcore. The instructions (screenshots) all refer to loading webcore in the Classic app as far as I can tell. Since I didn’t load webcore while I had the classic app, and I have since migrated to the new app and have deleted the Classic app, I don’t see where to load webcore in the new app.

Ok…here goes.

Click on + in the upper right of the dashboard
Select smartapp
Scroll down to the custom section and click on webCoRE,
Set up an instance of webCoRE.

After you set up that instance, you can find it from the menu (3 bars in the upper left of the dashboard)
Select Smartapps
Find the instance of webCoRE you created
This is where you will go from now on to add devices or configure it.

Or instead, install the Classic app and configure it there, you can use the app until oct 14, 2020 even though there are warnings at the top of the screen of the Classic app that you can’t :slight_smile:

We need to get someone to update the webcore installation instructions

There is no custom section in the Add

Smartapp. This is the entire list in these 2 screen shots

1 Like

Did you publish all 4 Smartapps in IDE and enable Oauth for the main webcore smartapp?

A screenshot of those in IDE will quickly show if you want to post. They show if they are published and true for Oauth. Don’t screenshot the entire page…just partial of the Smartapps for webcore.

I did publish all 4, and enabled Oauth. See below.

I just reloaded the Classic app. The My Apps section in Marketplace or in Automation > Add a SmartApp is blank. Does not show webcore.

Ok, I will ask just to make sure… you are logging in at https://account.smartthings.com to access IDE and install the code?

In Classic > marketplace > SmartApps > my apps > webcore to set it up. If not there, then answer question above :slight_smile:

So here’s something I never noticed before. When I log out completely, close the browser, and then re-launch and use your link to account.smartthings.com and login, it takes me to

https://graph-na02-useast1.api.smartthings.com/ide/apps

yet my bookmark was for

https://graph.api.smartthings.com/ide/apps

Under my bookmark, the Smartapps show up. Under the other one (N. America, US East I guess) , the Smartapps are gone!

What the heck is going on?

You were on the wrong shard.

You can use either the NA02 link or account.smartthings.com. Account will always redirect you to the correct shard which for you is NA02.

If you use the one you have bookmarked, it will not redirect you to your correct shard. Therefore, the code you installed will not be available in the ST app for you to use.

So, to fix… you will need to reinstall the smartapp code in the correct sh@rd. You may want to login to the other one first and remove the existing code so you don’t get confused in the future.

2 Likes