[DEPRECATED] webCoRE Installation Process Feedback

Please post feedback about your webCoRE installation experience. I am looking for things that did not work as expected, hurdles you encountered during the process, as well as suggestions that may improve the process. If your experience was fully positive, please limit yourself to voting in the poll, keep the discussion shorter and manageable.

How was your experience installing webCoRE?

  • aweful, got stuck and could not complete it
  • difficult, but I managed
  • could have been better, the installation guide was ok but I had a few issues
  • could have been better, the installation guide was not accurate, but I found my way through
  • great, everything went smooth and instructions were great

0 voters

Thank you

1 Like

The only problem I encountered was the 500 Internal Server Error when selecting both for github integration, which I didn’t initially see on the install instructions, since it is below the other steps, might throw a warning on the specific step of selecting them.


Likewise, I ended up installing them separately. Possibly just make that the instruction, forget trying to install both at the same time.

I also accidentally enabled OAuth on the Piston portion, I don’t know if it was necessary, but I removed it and re installed it. Teach me to read ALL of the instructions first.


Yep, the only issue was selecting both apps at the same time during installation. Took me 3 times to realize, I might need to search for a solution.

Also, since people are so use to doing things on their phones, it might be worth noting that webCoRE was designed for the browser. It’s a little rough trying to do things in webCoRE from your phone.

1 Like

Only issue was the adding both at once problem. After a few tries I just tried to do separately as part of troubleshooting. I didn’t even know there was an install guide as I was just using the paragraph in the top of the webCoRE design process thread. Reading the guide now it looks good although I might just instruct to install separate as others have suggested or add a red warning to line 11 where you select both. The other thing I found confusing was when first connecting my browser was the user ID/PWD. I was unsure if I was supposed to be entering anything there or not.

1 Like

I made the mistake of trying to add both smart apps at the same time from github. Adding one at a time worked fine. now I read the guide it says 1 at a time, not sure why I ignored that yesterday.

My process for Oauth was slightly different to the guide as I already had Oauth enabled for ActionTiles. I figured it out though.

1 Like

The wiki was updated yesterday by @whoismoses to reflect the findings. Thank you

The first portion of the install went great! But with yesterday’s ST app update, I can’t open the Automations->SmartApps tab to complete it. Is there a workaround until they sort it out?

Not that I know, sorry.

Actually, if you have selected any devices during installation, go to that device, tap on Smart Apps there and see if you can open webCoRE (or whatever name you gave it) from there. Let me know please?

You can go that route. I just tried it since I couldn’t get to it from SmartApps tab.

Hot damn! I knew you guys would find a way to get around it…

No problem installing because of my now understanding of application installations.

I’ve got everything installed and am capable of making pistons but the pistons don’t work.

I started with just some simple motion active turn on lights style of pistons but there not activating or giving feedback.

Try triggering the motion and waiting for it to go inactive at least once and see if it runs the second time around.

Also, set your logging to Medium at least, it will reset to None after 24 hours.

What version are you on? Also, enable logging? It defaults to None…

1 Like

Just updated an hour ago

Still nothing. Seems like I put in the simple logic but no light.

What is cast iron because it just gives me errors,

It’s a metal used to cast engine blocks. Other materials used include aluminum and magnesium alloys. It does not do anything other than displaying an error :wink: I plan on adding some premium features that will require a different engine block. Rule engine block, get it? :wink:


I’m thinking since there there’s no activity feed with webcore I’m missing a piece ST. not sure. My core pistons still trigger and give feedback. Kind of exited it looks really clean.

In the piston view, you have a logging level select box, set that to full and try making that piston do something. Pause it and resume it.
Also, this is not really the right thread - this is for feedback, not debugging issues. Try to move to the webcore beta m1 thread, please.

1 Like