Can’t get Family Hub fridge added to ST app


(James) #1

Hello all, I’m at my wits end with my very first Samsung ST device, so it’s nit looking good. I just got the Samsung fridge with the LCD screen and supposedly it has the Family Hub inside.

I set up a Samsung account. I have the fridge and my phone (iPhone 8) connected to the same WiFi. I have both logged into my Samsung account (using the ST app on my phone that has the logo that is a star of little circles). I select Add Device on the app and follow the prompts. It has me select “Easy Connection” (lol) on the fridge and connect my phone to the fridge’s WiFi. Then I go back to the app and I get the spinning wheel of death. It claims it can’t add my fridge and to try again.

I don’t know what I’m doing wrong. As a side note, the Bluetooth on the fridge and my phone don’t see each other either.

Thanks for any thoughts or ideas. I couldn’t find any answers with the search.

Regards
JP


#2

Are you in the Samsung Classic app or SmartThings Samsung Connect app? Cause if you’re trying to connect a fridge you need the later, SmartThings Samsung Connect.


(Gary T. Giesen) #3

I have the same problem with a non-Family Hub fridge (RF28K9070SR), as well as a WaterWall dishwasher (DW80M9960US). Tried using the SmartThings app on my Galaxy Note 8 running Android 8.0, and both appliances join the WiFi (I can ping them from another device), but hangs at 48%, with spinning wheel of death… I tried on my wife’s iPhone & iPad (running whatever is latest iOS), and they both hang at 98%, again with spinning wheel of death.

I’ve sent in error reports from the app to Samsung, but have never received anything back from them.

Of course the app provides zero feedback to the user as to what went wrong, so I can’t even troubleshoot it on my own.


#4

Most of this forum is dedicated to the classic version of SmartThings, like window open/close sensors, motion sensor, smart switches and smart bulbs. All of the new wifi appliances are new to all of us too since they used to be supported by Samsung Connect and weren’t under the SmartThings umbrella. So, unfortunately you may not get an answer from the forum on this one. May have to keep bugging support about it.


(Gary T. Giesen) #5

A interim update:

I contacted SmartThings support, who finally replied after 5 days that I had to contact another support department that deals specifically with the appliances.

I spent 49 minutes on the phone with them, during which they tried to tell me that my fridge isn’t supported it (it is, I sent them a screenshot from the app showing it in the list of supported devices). They are escalating it and supposed to reach back out to me within 24-48 business hours.


(James) #6

It ended up working for me. I had to go through the manual process where you pick your model number from the list, but it worked. The previous times I was trying to use the generic “Refrigerator (LCD)” option and it wasn’t finding it.

It’s been working great since then.