Can not pair Fibaro Smoke Sensor to ST

Hello Guys and Gals!

So I have the following equipment

ST (UK/EU) 2nd Gen
Fibaro Smoke Sensor (UK/EU)

I bought the Fibaro used from someone who never used it.

I have paired other Zigbee devices so I am assuming the process is the same as the Zwave?

So anyway, I have tried the following with no success

  1. I press the “b” button on the Fibaro 3 times and then I search with ST for the device, fail
  2. I tried to long press the “b” button on the Fibaro so it resets and I search with ST, fail
  3. I repeat step (1) after the reset but again fail.

am I missing something? Appreciate your feedback!


Check the model number of the smoke sensor as there is a version that’s not supported, can’t give you any more info atm as I am at work.

I have 2 working fine, but to pair you need to press the button 3 times very quickly. Also make sure it doesn’t get stuck in.

I pressed the button as fast as i could… I dont think this is the problem… any other suggestions?

Reset the sensor, do a z-wave repair then start the pairing prices again.

@siwilson thanks, but can you please tell how to do this? :slight_smile:

Not zwave repair but general zwave exclusion, but check the smoke sensor version


After watching a few videos on youtube, I learned 2 very important things that helped me solve the problem:

  1. If you long press the “b” button, it does not factory reset, it just does a systems check. The correct way to factory reset is: long press the “b” button until it blinks white and immediately let go. After a couple of seconds it will blink red, do nothing. After another second or two it will blink green, do nothing. Now get ready, as soon as it blinks YELLOW single tap the “b” button. Your device is now factory reset.

  2. In order to pair with ST you need to do 2 steps:
    (a) tap the “b” button 3 times fast in order to “wake up” the device. Note you are not in pairing mode yet (this was my mistake).

wait a few seconds and

(b) again triple tap the “b” button fast. Now you are in pairing mode.

So yeah, thanks to all that tried to help me out, I hope this thread helps others in the future as well.