[BROKEN] NST Manager v5.0 (Does Not Work Anymore)

Yeh just received another notification that there another critical update so maybe that fixes it but I cant find that update ?

I’m guessing there really isn’t much to be done. Null for the error code isn’t very helpful but at least I am not alone.

I’m having the same issues but I think Nest is the one having problems, my ‘Nest’ Account was set to away and yet had my ‘home’ temperatures set, think they’re having cloud issues or something.

This morning I was seeing API error messages, and updating to 5.5.5 worked for me, however I also opened the NST Manager SmartApp and pressed “save”.

Ok so think i’ve fixed it. Uninstalled from mobile app totally. Deleted from IDE. Re created in IDE and then re-installed in app. Took a lot of meshing about and a lot of time for what should have been a simple update. Why cant we have auto update app/device handlers ?

Use the Community Installer, it won’t auto update but it makes things a heck of a lot easier:

Hi - I have NST Manager up and running. I would like to create a smartapp that turns on a register fan (connected through a smart outlet) when the Nest thermostat goes into active heating or cooling mode. I can’t seem to find a logical hook or state to trigger the smartapp. Any advice? I’m a bit of a noob - sorry if this is real basic stuff. This forum is tough to navigate.

Webcore is the way to go.

If you use the Built-in automation app there is a fan control feature that does exactly what your asking for

1 Like

How do I update the the Wunderground weather location? The location I have set is not giving any data and I can’t see a way of changing it.

what exactly does “lite app mode” do? I didnt see a description in the wiki.

My Thermostat and weather information has updated since Sunday. Does anyone know what may have cause it. I’ve done all the recent updates.

There are several things to check

  • in the nest mobile app, ensure everything is ok (you can see devices etc, no messages about permissions, etc)
  • Then go into ST app (classic) and go into NM, again check for errors, and done/save your way out
  • if things are still giving you trouble, you want to look at IDE “Live Logging” and see if there are errors there.

There have not been recent changes to NM. I don’t know how long you have been running recent version.

You can enable remote diagnostics, and private message myself or tony to have a look.

1 Like

Just got notification that NST manager hasn’t received data
Logs show a few errors:

12:33:31 PM: error java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 439258652361800 @line -1 (apiIssueEvent)
12:33:21 PM: info ||| NST Manager (v5.5.5) | Updating Meta Data (forcedPoll)
12:33:21 PM: error getApiData (type: str) Exception: org.apache.http.NoHttpResponseException: developer-api.nest.com:443 failed to respond @line 3604 (getApiData)
12:33:21 PM: info ||| NST Manager (v5.5.5) | Updating Structure Data (forcedPoll)
12:33:21 PM: error getApiData (type: dev) Exception: java.net.SocketTimeoutException: Read timed out @line 3604 (getApiData)

And this (from initialize when saving):
12:34:57 PM: error org.springframework.security.access.AccessDeniedException: Access Denied @line 7739 (settingRemove)

I saw nest having API problems for about 15-30 mins. For me it seems to have cleared up. At the same time, the nest mobile app worked, but ST logs showed the null responses. So I don’t know if this was ST or nest.

You can go into NM, and done/save out.

In any case, I recently saw exactly what you saw for more than 15 mins

I am seeing some intermittent updates now but a lot of errors as well.
The Nest developer environment must be having some issues.

I started to see “API Status is: Has Issue” messages in the SmartThings device event log about 2 hours ago, Since then there have been about 15 “API Status is: Has Issue” and “API Status is: Good” messages logged.

1 Like

I’ve been getting these sporaticly the last few weeks, thought it was just me so I debugged everything, ended up doing a complete uninstall/reinstall. Now I cant even get it installed, get stuck when trying to install the app and log into nest. I log in but it just times out and says “cant refresh” or something.

I really hope google provides some type of official integration soon even if via ifttt, this is such a complex solution for a simple need.

Any way to fix this problem, I just started getting it also. Nest app works fine.

Me too - and again right when it gets cold.