Broken automations and inoperable Zooz devices - please help! (July 2023)

Things were going good until about a week ago. The additional buttons on all three of my ZEN32 scene controllers have stopped working and when I go into the app and click on each one it displays “This device hasn’t updated all of its status information yet. Check again later.” When I tried adding a ZEN34 remote switch 2-3 weeks ago it adds it successfully, but when I click on it to set it up it displays the same message. I’ve contacted Zooz and they said that Smartthings has done an update which broke many automations and that the incorrect Edge driver was loaded onto devices. Is there a fix on the horizon or does anyone know how I can fix this?

1 Like

If you’re not already, use the official Zooz drivers for your ZEN34’s.

  • Install the driver from the link above to your hub.
  • In the mobile app, go into the device’s tile, and under the “3 dot” menu, select “Driver”. Then “Change Driver” to the Zooz driver you just installed. You can also select a new driver for a device in
  • You may need to refresh (pull down on the screen when in the device details UI in the mobile app) to get all the values to sync.

All my ZEN34’s are switches instead of remotes in Smartthings now, so inoperable! :frowning:

Did you install the official Zooz drivers and switch your ZEN34’s to them? Instructions are 1 post above yours.


I tried that but then the device wouldn’t respond. I just tried adding it again though and it worked! Thanks!