[BETA] NorthQ Q-Power - z-wave power meter

devicetype
dth_powermeter

(Anders) #1

First implementation of device handler for the NorthQ Q-Power meter. Homepage for the product: http://northq.com/qpower/

See the comment on the handler for links to further details.

Not all options are implemented yet but:

  • Option is set to electronic meter (lamp that blinks)
  • GUI option to set blinks/kWh

Reports energy and battery.


(Jason Moody) #2

Do you think this would be adaptable to their gas meter, to be honest looking at the 2 products gas and power I cant see what the difference is, they both appear to work by monitoring the reflective dot on a wheel meter, or the blinking led.


(Anders) #3

Maybe. You’d really want to compare the features/commands from the page of the Z-Wave Alliance. But I can’t seem to find a gas meter there?

Here’s the link for the power meter: http://products.z-wavealliance.org/products/69


(Jason Moody) #4

The spec sheet is here http://northq.com/wp-content/uploads/2016/11/Q-Gas-Specifications.pdf


#5

Hello Anders,

Thanks very much for creating this device handler.

Please excuse my lack of ability - I’d like to enter my electricity meter’s current current total, so the KWh total is correct (it currently shows usage since I installed the NorthQ logger ~8KWh)

I appreciate there isn’t a front-end / GUI to enter this value into, but could you possibly advise me where to add my electricity meter’s total to the KWh total variable in the device handler?

Thanks in advance
Al


(Anders) #6

Hey Toff,

I’ve updated the handler now with an option for base value. It’s barely tested, but check it out and let me know if it works or not. :slight_smile:

Anders,


#7

Hi,

Thank you so much Anders - that worked perfectly after the NorthQ device did it’s next update.

I’m now getting all I need from the NorthQ power meter - all thanks to your Anders :smile:

There is one little bug I’d like to report - just a small thing. SmartThings forces you to use an icon for each device. As you can see from my screen-grab below; the icon gets superimposed (put on top) of the kWh reading. Is it possible to add the equivalent of a few

to solve this? :grin:

FYI: I have an iPhone 7 (standard size, not the Plus) running iOS11.

Many thanks indeed
Al.


(Anders) #8

Ah, that doesn’t occur on Android. Try the new version, I’ve increased the height of the tile to try and avoid this. :slight_smile:


#9

PERFECT! Thank you very much

Now I can see it clearly and can cry at my family’s energy consumption :sob:

haha