Belkin Wemo Light Switch won’t pait with Smartthings V3

Hello, I am currently migrating from a V2 to a V3 hub (which is painful- I don’t recommend it) and I’m having problems pairing my belkin wemo light switches with the V3 hub.

These used to work well with the V2 and currently work well with my Amazon Echo and the wemo app but aren’t seen by my V3. I have tried with the new Smartthings app as well as with the classic app to no avail. Have tried powering off and repowering the hub unsuccessfully. My hub is connected via Ethernet to a Linksys Velop and the wemo lights are hooked up to the same network via 2.4Ghz wifi band.

Any advice?

Bump - help pls!

Bump - - -

Pairing is probably not the right term for WEMO devices. They are the only devices that no migration is needed. I have them added to both my V2 hub and the Connect in the new ST app and I can control them under either hub setting. You probably want to try the classic and the new app. There are things that I have got between the 2 app to get it working.