Wemo Switch present in Belkin Connect, but not Things

First time poster, so let me know if you require any sort of specific information.

As described above, I have added yet another Wemo switch to my SmartThings setup. This will be my 7th light switch and I have an additional 3 Wemo outlets. I say this because I have a decent idea of basic troubleshooting and wiring them. So, to start, the switch is accessible in the Wemo app and is controlled correctly. Likewise, it is controlled correctly from an Echo. When I try to add the device in SmartThings, it shows up in Wemo Connect SmartApp along with the other 6 switches. I make sure all of them are checked, then click done. The app updates and says “Wemo Connect was successfully updated.” I then proceed to the Things tab, and the device isn’t present. As a last ditch effort, I also tried to reset and re-add the switch, reboot my phone (and thus SmartThings App), restart the hub, and I even tried to remove the Wemo Connect smart app but was unable to do so do to an error (unable to remove due to an error according to SmartThings). I’m kind of at a loss at this point - hopefully it is something stupid I missed, but can anyone give me any guidance?


edit: I should also add the other 6 switches and 3 outlets are properly controlled by SmartThings.

Can anyone help?

If it is shown in Wemo connect app, but not in ST things, I would contact support and see if they can find it in limbo somewhere.

Okay, I’ll do that. I thought they wouldn’t help because Belkin is part of the “Labs” but I’ll give that a try and post back.