Bathroom lights randomly turning on despite complete deletion & readding

Hi guys, I’m an advanced smart home user with over 60 smart devices in the house. It’s rare to be stumped but this has defeated me:

Randomly, the bathroom lights turn on full brightness. This is a particular issue because we have a newborn, and when bathing her at night during our dimly lit wind-down, the lights will just come on full blast. It wakes the baby back to 100% and is making the wife hate the smart home, which of course comes back to me ¯_(ツ)_/¯

What I’ve tried:

  • I did have the Labs “No worries while away” app in SmartThings that can turn lights on and off when the house is set to “Away” set up. But I have deleted/uninstalled that integration. I even reinstalled it, and made sure the bathroom lights were not part of it, then uninstalled it again. But yes, bathroom lights were part of it when I had it set up.
  • When this happens, SmartThings Home is not set to Away it is set to Home. So the Labs shouldn’t be happening regardless.
  • I found an orphaned lighting group at the web interface called “Summary-lighting-group” that had bathroom added to it, so I deleted that too.
  • I have rebooted the hub, and in fact disconnected it and moved it to a different location in the house (for another reason).
  • I deleted the actual light bulbs that are coming on at 100%, and re-paired them to SmartThings with different names to before. It still happens.
  • There are no Routines connected to those lights, other than the ones called by the Zooz remote light switch (basically turns the lights on and off if I toggle the wall switch up or down).
  • When it happens History just shows “Bathroom ceiling light 1 new - Power: On” “Dimmer: 100%” with no info of where that call came from
  • I don’t have any other routines that could be doing this for example in Google Home etc.
  • These lights are Sylvania Lightify: They have worked fine for years. I can’t be sure exactly when this started happening, and I changed a few things over that time.
  • These lights are Zigbee.

My hunch is it’s something to do with that uninstalled Labs App. My second guess would be the Zooz switch.

Can anyone help me get to the bottom of this please? Thanks.

What is the lights model and make?
It could be just a poor implementation of the firmware.

I’m using @Mariano_Colmenarejo ST driver with Ikea lights and bulbs and works perfectly.
It dims light after 22 and sets to full brightness at sunrise.

If you use Alexa and St is linked to it … check if Hunches is enabled in the Alexa app. It could be that Hunches has created a Routine in Alexa to turn on the light. Disable Hunches and disable the Routine in the Alexa app.

1 Like

@veonua They are Sylvania Lightify 65:

They’ve worked fine for years. This is a recent problem.

Are you recommending I try a different driver? Can you link to the exact one you recommend please.

I do not have Alexa @jkp

1 Like

That’s related to the summary lighting tile in the app. You may find it returns.

Can we infer from that comment that you have SmartThings linked to Google Home? The rather loose matching of voice commands might defeat renaming of devices and there is always the risk of bridging to other households if you aren’t careful to avoid it. Mind you if that were an issue I’d have thought you’d see more widespread problems.


Have you checked if you have general power microcuts or in the light bulb circuit?
If power is lost when recovering it, they turn on by themselves at 100%.

Try disabling the firmware update for zigbee bulbs on the hub.
Although this does not happen regularly, when the firmware is updated the bulbs normally turn on.


If that were the case, would it show up in ST history as an event “Dimmer 100%”? I think that unlikely.

It happens several times a day. It can’t be firmware updates.

Yes I have Google Home but no other households. No other problems in other rooms, just these ones, that I had linked to “No worries while away” Labs app.

Do you by chance have a timer in the switch settings?

If the bulb is on at 100% dimmer and you remove the power then when you recover the power you will not see any new events in the history, since there is no state change.

If you have set a dimmer other than 100% (50%) and you turn off the light bulb then if you remove the power when recovering it you will see an On and level 100% events because there are two state changes, from off to on and 50% to 100% level

Every time the lights come on they report both the “On” action and the “Dimmer 100%” action, even when I have not changed the dimmer setting in between the unwanted events. This tells me the command is coming from ST not from a power interrupt.

No timers are set.

Here’s a closer look at the ghost activity:

What’s interesting that I hadn’t mentioned before is how the events typically go something like this, all within the same minute/second:

Power Off
Dimmer 93%
Dimmer 20%
Dimmer 54%


Power Off
Dimmer 95%
Dimmer 45%
Dimmer 100%

That’s in order of action. So it’s turning the light off, then up, then down, then up. These are all marked at for example “12:48 am”.

I would be suspicious of “No worries while away” Labs app causing your problems.

If I were having this problem, I would delete the device, reset it and repair it with the app. That should break any ghost automations.

Please see my first post:

  • I deleted the actual light bulbs that are coming on at 100%, and re-paired them to SmartThings with different names to before. It still happens.
1 Like

Might you have a Smart Lighting automation setup? I can’t remember if those show as a routine in history or not as I have moved most of mine over. I feel like they don’t show. .

No, Smart Lighting is empty. I did have something in there for syncing a hallway switch but not any more.

Does anyone know a way to change the unique address of a bulb so when I deregister then reregister it, it seems foreign to whatever is causing this? I really don’t want to have to spend $230 on new ones.