Bali Somfy Autoview Zwave Device

Hi Everyone:

I searched the forums but I couldn’t find my same issue. I just purchased new Bali Motorized Cellular Blinds for my house which comes with the new zwave motors and tiny remote they call “Autoview”. I was able to pair all the blinds up to Smartthings and used the “Zwave Switch Generic” device handler. All of them seem to work except for one…

I have a patio door that I installed the blinds on that’s taller than the rest of the shades. On this one It will listen to Up (“On”) commands but once it’s in the fully open position it won’t take any commands to turn off… If I manually hit the button on the actual motor to make it go back down it seems to reset itself and works with Smartthings again.

Has anyone had this issue? Is there a way for me to log the device state so that I can troubleshoot?

I’m thinking it has something to do with the height of the shade and the travel time. I can’t see how it’s any different from my other blinds.

PS: Also wanted to add that I tried a custom Device Handler from “Whoismoses” with no luck either…


Have you tried setting the maximum height of the shad a little lower than the top? Your instructions should be able to tell you how. If I remember correctly it was something like…

Also, when you use the supplied remote to put the had all the way up, will it go down using the remote or do you have to reset?

Have you tried removing and re-adding the shade to SmartThings? Also in a worst case scenario you can reset the shade completely and try. But be warned, when resetting the shade, you will have to pair the remote back to the shade as well as set your upper and lower limits again or the shade will only move about 3 inches in each direction. Also if resetting its always good to have the shade halfway open… easier to troubleshoot vs fully closed or fully open.

To reset the shade press and hold the button on it’s headrail, it will flash green, eventually flash red and then completely stop flashing at which point you let go. Then simply press the button on the shade to check if its only moving 3 inches in each direction; if it is you have successfully reset the shade.

You can find videos on adding, removing, and setting upper and lower limits here: Z-Wave + integrated blinds/shades: Custom Graber Virtual Cord Shades

Yup, I tried setting the maximum height a little lower than the top but that didn’t make a difference. I also updated the device handler code that you provided to set the max opening height to something like 96 or 98% and it still gets stuck when it’s up/on…

When I pair back with the original remote it doesn’t have any issues… This is really puzzling.

I tried unpairing it with Smartthings and then re-pairing it again it still no difference. I even tried the reset method that you suggested and it will only respond when it’s in the down/off position. When it’s open it won’t come back down.

It might just be a defective shade then. Call Bali consumer customer service and you should have a Bali order number that you can reference, they should run you through some of the trouble shooting I mentioned. If all else fails they should go through with a replacement. Explain your problem and ask to be connected to a product specialist or an advanced tech for the autoview. If you had the Graber versions I could have helped out directly.

Thank you, I’ll give them a call.

I’ve looked over my code and I can’t see why it wouldn’t work for this particular blind / shade. I think @ZebraBlinds is right that it might be defective.

One more thing I would like to add, for a few customers we have also noticed that any unusual problems were resolved with 1 - 2 resets. So I would suggest giving a full reset one more go. If that fails you need to get Bali to issue a replacement and an RMA label for the existing shade.

BTW - Can you try to manually install this Version?

Don’t use it long term. Just let me know if the on/off work.


I tried that new code and behaves a bit differently but still finicky. So this time I got it to respond in the on position and it was able to turn off but after that it wouldn’t respond anymore until I manually hit the button on the blinds.

Also, with the new code, the device state is more accurate. It’ll show “turning on” or “turning off” as opposed to just immediate on/off. When I hit the refresh, it now refreshes and shows the correct device state. I don’t know why it’s so finicky with smartthings when all my other blinds work fine. Also works fine with the remote that it came with…

I tried reseting it a few more times like Neal suggested. It seemed to have fixed it for like 5 minutes and then it went back to not responding to smartthing commands :unamused:

I’m not sure Bali would help me out since it works fine with their included zwave auto view remote just not with smartthings. Driving me nuts, been fiddling with it all morning.


Also, I checked the Device events to see what’s going on and it looks like the app is sending the “on” command to the device but it’s just not responding. Is there a way to code the command to make it send the “on” signal for a longer duration?

I don’t believe so. The first device handler is the one that is most up to date. I just wanted to you test the old one.

So Bali should help with a replacement. As long as you can get them to trouble shoot things over the phone with you and connect to an advanced tech or product specialist and make them understand the problem, you shouldn’t have any issues. You could also try the place you purchased it from (but your mileage may vary on that one, because unless they have a proper understanding of how the shade works and what it can do; they will be useless in terms of helping get it replaced). These shades were made to work with HA systems and if one of them is acting up Bali should replace it. I also suggest making a video showing the problem so you can send it to them while talking over the phone.

Thanks for the tip Neal. I’ll give them a call tomorrow.

Were you able to get it sorted out with Bali?

Hi Neal,

I haven’t had a chance to call them. Luckily, last night I fiddled with it some more figuring I’d do another reset just in case.

After messing around with it for some time I think I found the issue… So I have the cellular blinds and when it was retracting to the on position the antenna in the back would get folded up in between the cells. Explains why it only worked going up but not down.

Anyways, I pulled the antenna out and it seems to be responding to commands as expected now (knock on wood).

Thanks for the help on showing me how to reset!


1 Like

Ha! Glad you got it sorted.

Great! And that’s definitely a new trouble shooting tip for me :smiley:.