Art Mode Same Network Error

Just connect the frame tv to your phone hot spot. Upload your images then change it back to home router network. after you have uploaded your images.

Upload images by connecting the tv to your phone hot spot.

This isn’t working for me. Stopped working a couple months ago.

Samsung Frame 2017

Google Pixel 7 Pro

Latest version of Smartthings app.

Reinstalled Frame and tried all the tricks.

Any other ideas?

Edit:: I have raised a support ticket with Smartthings. Let’s see if they can help.

Hi I tried all methods above but didn’t work. However, I found a way that worked! I want to share my method as I know it can be really frustrating dealing with this issue.

My way only works if you have 5G and 2.4G network. In most cases, you have 5G too if you have 2.4G too

My TV was connected to 5G but the upload pic function no longer worked

Step 1: connect your TV with 2.4G network and then connect your phone with the same 2.4G network

Step 2: now go to your art mode and look at your “my photo”. You should be to change mat of any existing photos.

Step 3: go to your TV and change the network back to 5G . You should be able to control art mode even with different network (TV 5G, phone 2.4G)

Step 4: connect phone to 5G

1 Like

I’m at wit’s end here with the same problem. This worked fine for years but I recently switched phones and now I receive the network error message every time I try to upload a picture. I have tried all of the suggestions in this thread so far but to no avail.

On my Frame TV, when I look at the Allowed Devices list, I see my new phone, but Smart Things is not listed as one of its allowed services. My old phone is still listed and it does show Smart Things as one of its allowed services, so I suspect that this i related to the problem.

Any suggestions about how I might rectify? This is really ridiculous that this is such a problem in 2023.

Good news for android users - I was having this same problem and losing my mind, when I decided to try downloading an older version of the app from when I remember it working. Sure enough, I was able to load three more photos onto my TV. I used this APK from March 2021, though a more recent one might work: https://m.apkpure.com/smartthings/com.samsung.android.oneconnect/download/176023010-APK

well, i’ve tried absolutely everything, every option on multiple forums, every permission, every suggestion above and kept getting angrier as people kept saying they found a fix… well, not for my rubbish The Frame TV… i was using a Pixel 7 Pro, switched to my previous Pixel 5 and tried on the wife’s iPhone… nothing, spent hours on this… so, finally remembered my daughter had a very old Samsung phone abandoned in a drawer somewhere… and for crying out loud, it worked straight away… my fix is, for Samsung things, use Samsung devices or better yet, don’t buy Samsung.

I had this issue - the cleanest solve is that you must import smart things hub and the device into the same room on the devices tab - all the other work arounds are basically trying to fix this.

I turned on local networks specifically under the smart things app in settings. Fixed the issue immediately.

When I turned off Private Wi-Fi Address in connected network settings, it is solved. It is iOS by the way

I had the same problem with my iPhone, but it worked on a Samsung phone. Then I found out that my iPhone was disconnected. Try going to Settings → All Settings → Connection → External Device Manager → Device Connection Manager → Device List.
My iPhone was disabled in this list, and after allowing it, it finally worked! :slight_smile:

Same issue - fixed by turning off 5gz band on broadband router - then your phone and tv now on 2.4gz - refresh app on phone and will show an error - click Refresh again in app and you will then be able to upload your photos to frame.

Remember to login to your router after this has been uploaded to turn on 5gz again!

Hope this helps others…

1 Like

You must be the smartest person on this planet!!!
THANK YOU!!!

For me the problem was that I had the TV connected through LAN cable, which also does not work, although it’s the same LAN in the end. Connecting the TV to WiFi solved my issue.

This worked, thank you

I use an iphone/ipad and just bought the samsung TV.

I tried every recommendation here and none worked. But I found a fix, inspired by this person (thanks Kevinjamesrobinson). I messaged my internet provider (I use Spectrum) and I asked them if there was a 5.0gz and a 2.4gz option, or a way to toggle between then. They told me they’ll turn on a 2.4 version for 1 hour to let me TV connect. And it worked! As soon as there was 2.4, my TV connected and I can upload photos.

So my recommendation is to see if you can get your wifi provider to guide you to stream 2.4 temporarily (or some people have two wifi options, one 2.5 and one 5). It worked for me right away! and no need for Samsung support thankfully!

1 Like

I have a iOS and found a simple solution that worked for me from a Reddit thread.

It has to do with your settings/permissions for the SmartThings app. You need to allow it to “always” track your location, and make sure all other permissions are turned on as well.

After going back to the SmartThings app, you might get an error after clicking art mode that the connection is not stable, but selecting “refresh” should work and allow you to add your photos. Good luck everyone!!!

What seems to work consistently for me is to go into your Internet settings on Android and click on that little reset network icon. It looks like a refresh button on the top right above Internet. It’s much simpler than changing router settings or connections on your TV.

Just wanted to share my :man_facepalming: moment. I was struggling with this for over an hour today. Then tonight it hit me - I run a VPN (ExpressVPN) on my phone (iPhone). Once I turned the VPN off on my phone everything worked again for me.