Arrival Not Triggering 'Home' - Please Tell Me What I'm Doing Wrong

I figure I must be doing something wrong, as arrival seems never to work…

Specifically I have 2 routines to be triggered with presence sensors:
1 to go off when ALL presence sensors leave.
1 to go off when ANY presence sensor arrives.

The ‘all leave’ routine works without any issues, the following two images shows all 6 sensors are away, and the state is set to ‘armed’:

Now the following shows the ‘Home’ routine which is the one causing me problems. All the screens below suggest if any ONE sensor arrives, it should be triggered:

Now the following shows arrival of ALL 6 sensors, any ONE of which I believe should trigger home and set to ‘disarm’:

He following however, shoes that in spite of ALL 6 sensors having arrived, the ‘Armed’ state did not change:

Needless to say, when the front door was opened:

Now, to show there is nothing wrong with the ‘Home’ routine, the following shows I manually ran it:

That the ‘Disarm’ state was properly set:

Seeing as ANY ONE sensor should trigger ‘Home’ and ALL 6 combined don’t trigger anything, I have to assume I have done something wrong in setting things up.

Can anybody tell me what I’ve missed???

1 Like

You should check live logging to see if devices are coming and going correctly.

There are a few people reporting presence issues the last few days.

This issue is a lot older than a few days…

In fact I started noticing the issue > 8 months ago. I eventually fully disabled the arm/disarm setup after getting tired of not being able to get it to work…

I just recently started trying to get it to work again, but am still seeing the exact same problem…

When I had problems with routines not completing weeks ago, I fixed it by removing Harmony activities from my Goodbye and Goodnight routines.

When I had the same problem start again over last two days, I fixed it by removing Nest thermostat from all routines.

I Think there are number of different things it can cause these issues, which is one reason they are so hard to pin down.

The first question, of course, is the presence sensor being recognized. You’ve probably already seen this one, but here’s the steps to go through to verify that

There used to be a problem with routines where if a routine set the mode, but the house is already in the mode that it was going to be set to, then nothing for that routine worked. This was a very common issue for people who had more than one person listed as arriving for the same routine.

I think this was later fixed for a while, but I have begun to wonder if the same issue has come back. I haven’t had time to test it myself, but I just mention it as something to consider. In addition, the fix to this approach is to break out your routines so that you have one per presence indicator and that can really help with troubleshooting.

I hadn’t previously heard about the issues with harmony or nest or other third-party services, but there may be a synchronization issue going on.

I wish I had an easy answer but there doesn’t seem to be one. :disappointed_relieved:

If you remove some presence does it work? I see you have 3 per person.

Still look at live logging to see if presence is getting triggered which in turns tirggers the action.

Try making a new routine, perhaps the home routine got corrupt during all the issues a few months ago and its not really monitoring the presences you added.

I’ve been having the same issue every couple weeks. What seems to work for me is going into the IDE and go to list smart apps and hit the update button. While I’m in there I just hit all of them. If I’m not home I just go to the mobile app and open Smart App and then hit done. If I have any problems that’s the first thing I do. A while ago tech support was recommending doing that whenever you have a problem

I have noticed in the past whenever they do a behind-the-scenes update, that isn’t a hub update sometimes things don’t work right so I just update my apps and it seems to fix everything.

When I had problems with routines not completing weeks ago, I fixed it by removing Harmony activities from my Goodbye and Goodnight routines.

When I had the same problem start again over last two days, I fixed it by removing Nest thermostat from all routines.

Neither of these apply in my case. I don’t have Nest, and while I do have harmony, I have not been able to get it setup (it errors out when I try) so it isn’t implemented in any form under my SmartThings…

I’m left with the impression that presence is working, at least to some degree, as my away mode is automatically triggered EVERY DAY after both my wife and I leave (it works 100% of the time exactly as one would expect).

It will never trigger until both of us leave, regardless of order (her first, me first, both at the same time), and seems to always trigger when we are both gone.

It would also appear that ST is properly detecting our arrival home, as the indicators inside the app always show ‘away’ when expected and ‘present’ when affected.

There was a short period when my wife’s phone was stuck as present in spite of her leaving (and away never activated as a result), but this was fixed after running ST on her phone & logging her account back in (there seemed to have been a disconnect from her account).

I’m not exactly sure what you mean. how do I go into the IDE to hit update???

Make a new brand routine for Home. There was a lot of corruption a few months back with states in the backend. You may have some lingering issues. Working on Nest-Manager we had to tell quite a few people to just delete the smart app and reinstall to get it working again.

Go to my location, scroll down to the bottom click on list smart apps and there you go. There will be an update button next to all your smart apps

1 Like

The routine I have is a couple weeks old, I completely deleted my routines when I started over recently… But I guess no harm in doing it again…

I ended up finding. a bit of a work around, having IFTTT trigger a virtual with that starts home based on iOS location. Not happy I had to resort to this, but it seems to be working,

1 Like