Arm and disarm not working when I leave or arrive


(Troy) #1

Not sure if this is the right place for this post, but here it goes.
I think I set things correctly to arm and disarm, when last person leaves and someone arrives, but it is not working. I tried searching forum with no luck to a solution.
Is there some other setting I need to activate or something to make this work?
Currently I am the only user set up.
Any ideas?


(Ron Talley) #2

I use the regular ST Routines for this. I’m Back and Good By. I use our iPhones for Presence Sensors. Have worked but you can also set it up in CoRE.

For leaving use All for coming use Any

Latching Piston
If All Presence Sensors are not present Then Arm
But-If Any Presence Sensor are present Then Disarm


#3

Depends on exactly what are you using. Are you using a routine? If so, can you post the screenshots for what you have set up? Smartthings is very powerful, but not always very intuitive and small details can make a big difference.

Otherwise if you contact support they should be able to help you with this:

https://support.smartthings.com/hc/en-us


(Troy) #4

I am attempting to use "I’m Back and Goodbye!
I am also attempting to post screenshots.:grinning:


(Ron Talley) #5

What do you have selected under Everyone Leaves or Someone Arrives?
Are these Phones?
If so, are they logged in on the app?
If one of the “Everyone Leaves” phones have logged out of the ST App then according to ST they are still home if that’s where they logged out…

At least this happened to me. Under Family, goto history and see when the last log updated.


#6

Also if you have yourself signed into the SmartThings app on more than one device, such as on a tablet and on the phone, and you leave the tablet at home you will continue to show as at home.


#7

Try adding turning on a light as well just to test if the routine is running at all. Also, are you seeing the mode change when it should?


#8

Finally, you only gave us screenshots a part of the routine, we need to see the whole thing. In particular, you’re missing this page, Advanced options, which should be below the “perform automatically” setting.


(Troy) #9

I am the only one using the smartthings app.
It is only on my Android phone( no tablet or other phones).


(Troy) #10

JDRoberts, when you say add a light, I will have to check this when i get home to see if the light comes on? correct? or can i just check things and see if it’s status is changed to on when I am away if I add it to the away command?


#11

You should be able to just check its status.

Also, try taking off the “don’t automatically perform this if I am in away mode” I think sometimes there’s a timing issue where it shifts to weigh mode before the arm get set and that confuses everything.


(Eric) #12

Ever get this fixed?
Its happening to me. I just recently started using these features.
Twice in the past few days i started getting madd alerts because sensors are still in away yet my wife is home. I check the family tab and it says she arrive shortly before. The status is still away and alarm is still armed. both of which should have been changed by the I’m back routine. My routine is nearly identical to yours.


(Troy) #13

Eric,
When I had this issue, i just started over and set things up the way others showed previously in this post.
I have had very few issues since, (usually when i do, it is because the wife’s phone got logged out of smarththings, maybe from an update or something.)

other than that, I do not know enough to be any help to you. I have not had much time to mess with my smartthings.