Arlo Wirefree Camera Integration Update 9/13/2016

Hello Community,

A small update to the Arlo WIrefree integration is rolling out today. Changes are as follows:

  • Added ability to set/change camera sensitivity in device edit screen.
  • Fixed Livestream timeout error being generated when batteries are dead.
  • Fixed issue where Livestream methods were called when camera is off.
  • Fixed issue where Arlo App generated video events would overwrite last saved ST incident video.
  • Added additional detailed logging for performance metrics tracking.

Thank you all for the previous feedback and we hope you like this update. Don’t forget to put a bunch of stars (5) on Amazon, Play Store and/or App Store when you get a chance. :wink: Positive reviews ensure the Engineers and Developers get extra food and water. :blush:



Awesome! Is the update automatic or do I have to manually do something?

It will be automatic. As we all know, it sometimes takes up to 24 hours to fully deploy. I think it follows the sun or something. (Joke)

To use it: Tap the gear on the upper right of the device detail screen, then tap edit device. You’ll see the input entry point sitting there nicely on the bottom of the list, waiting for some yummy numbers. :slight_smile:

1 Like

Am I able to change the sensitivity based on the current mode?

For instance, I like the sensitivity higher in my “Overnight” mode than in my “Away” mode.

Is anyone monitoring @twack 's account while he’s on vacation?!

Vacation? I wish :slight_smile:

Was giving you the benefit of the doubt. Six days without some type of response to a question is unlike you.

Ah, sorry. Sooo many irons in the fire.

The answer to your question (assuming its the one above) is: "No, not at this time."
You can submit a support email to request the enhancement though.


1 Like

Is there an update on when the Night Vision bug will be fixed, because I’ve had to disable the night vision in order to save my batteries. Since the integration, with the wireless cameras turned off, they still register motion every time someone walks past, ALL the red lights go on, for the indoor camera this is especially problematic as the camera wakes every 30 seconds and the red lights are alarming, hence keen on a fix.

Apparently its a Arlo bug (because it can be reproduced even without ST integration, see my steps at link you mentioned) and Netgear is silent as usually. JamesC promised an update but never delivered.
The only thing that ST can do about it is to introduce Motion ON/OFF capability (highly anticipated). But again, they most likely should work with Netgear on that.

(or someone should look why AutoArlo stopped working:)

1 Like

Hopefully Mr @twack can use his charm and panache to speak directly to Netgear to fix the Night Vision bug very soon.

Yes the AutoArlo smart app was VERY convenient, if that gets fixed it would be amazing. I’m thinking “they” broke this method on purpose, but I certainly won’t pay a monthly fee to few video clips in SmartThings when I have them for free with the Arlo app. Bring back AutoArlo!

1 Like

I have been reading up on this Arlo ST integration and relationship quite a bit and I might have stumbled upon some helpful settings…so here it goes:

Using the settings below, renders these desired results:

1 - The motion sensors on my three Arlo cameras seem to stay inactive and not use battery.

Confirmed from a refreshed current state panel in the developers panel. In fact when they do go active for SHM or a custom rule, the red lights for night vision mode come on and stay on for the duration selected (30 sec, 1 min, or 2 min) but the motion sensor returns to inactive within seconds, confirmed with a repeatedly, quickly refreshed browser.

2 - The cameras remain active and available to be turned on via SHM or custom rules with no lag.

3 - The cameras send the same duration clip to ST mobile app (visible in intrusion alert and in history) AND to Arlo (even though “do nothing” rather than “record video” is selected in ST mode within Arlo settings) In fact, the duration of the clip saved to Arlo matches the duration selected in ST, 30 sec, 1 min or 2 min, huh.

Settings: (I got lucky, wouldn’t have tripped over it w/o all the feedback above and on other posts, thanks!)

Within Arlo:

1 - Click on SmartThings Custom Mode
2 - click edit next to first camera
3 - Make sure to select the same camera under “then do the following” as is selected under "if the following"
4 - Select do nothing
5 - Select push notification
6 - Click Save
7 - repeat steps 2-6 above for each camera

Now the motion sensors are not active and do not cause any recording to happen via arlo until ST tells it to do so, via either SHM or a custom rule.

So now use SMH or custom rules to setup when to use each camera for recording.

I currently have mine set to record when glass break sensors or door open/close sensors trigger when “Armed (Home)” and set to record whenever any sensor goes off when “Armed (Away)”.

This is only my third day with the ST system, and I have yet to set a custom rule except for testing. I hope to set up the cameras to record only when their own motion sensors trigger (or adjacent glass break), rather than all three cameras recording when any door or glass triggers when home, or when any sensor triggers when away.

Turn off notifications for the Arlo App on your mobile device, or simply do not install it. For me, the clips on the ST mobile app, and the backup copy on Arlo is sufficient. Since I do not use the Arlo app, just STs mobile app, I never see or hear the notifications from Arlo. So the notification remains out of sight and outta mind:) Weird thing is that Arlo would not let me save my settings unless either the notifications or the email alert box was selected. I def don’t need any more email, ha, and in this case an invisible notification is perfect!

I do like having the double copy on Arlo, it is easy to see all the clips at once and navigate through bases on timeline; and can view on a larger screen if needed.

More weird things are that the duration settings within arlo will always default back to 10s no matter what you do or how many times you try to save them. Don’t worry about this, use the duration settings within SHM or custom rules and Arlo will follow suit. Another weird thing is that the “motion is detected” box in the “if the following” settings is clicked on by default and cannot be deselected. This does not affect this scenario, but is any additional observation.

Any feedback is appreciated, I just hope this helps someone with their scenario.

1 Like