Arlo ST Integration

Good Morning,

I decided to try my Arlo Pro 3 integration again since it’s been a few months. I’m having more success this time. I have noticed one issue though…

  • I keep my cameras armed in the Arlo app
  • I use ST automation to turn cameras on/off based on ST mode (Home, Away, etc)

When I come home, ST mode is switched and cameras show to be off in both ST and Arlo, but, some are still detecting motion because I see the spotlight on the camera come on when I walk by. There are no recordings in the cloud or notification sent, but, the camera is definitely triggered every time I walk by.

I am also noticing that when I leave and cameras are turned back on, occasionally they act as though they are disarmed (no notifications or recordings) even though they show to be “on” in ST and armed in Arlo apps. This is resolved by going into the Arlo app, disarming and rearming them, they seem to work then…

Any ideas? @arlo_eng @shravan

Hey @Brad_ST. I’ve seen in other threads where you have been working with Arlo issues. Do you have any ideas on this? I can’t seem to get replies/help from anybody !?!?

The automations are working, but, the behavior of the cameras (occasionally still on when off and no alerts or recording when on) are making it unreliable to the point I have shut the automations off.

I’m not super well-versed in Arlo but shouldn’t the Arlo mode be set to “SmartThings”?

We’ll…. I’m not either… LOL. Where would I set that? I haven’t seen anything that gives me that choice…?

Regards,

Bill Wolfe

https://kb.arlo.com/1132961/How-do-I-integrate-my-Arlo-cameras-into-the-Samsung-SmartThings-app

When you integrate your Arlo cameras with SmartThings, a new SmartThings mode is created in the Arlo app. Because SmartThings manages your Arlo cameras, they must be in disarmed mode. You cannot use schedule mode or geofencing mode at the same time as SmartThings mode.

Under Mode you should disarm the cameras and then on the same page in the Arlo app you should see your basestation. Tap on that and you should be able to select SmartThings mode if it isn’t already selected.

Well…. I don’t have that mode available…?

Regards,

Bill Wolfe

Nope, not anymore. So the KB you referenced needs to be updated.

1 Like

Thank you, Brad.

You’re the only one who has even offered any help.

I’ll uninstall and try it again according to the directions. I’ll let you know the results.

Regards,

Bill Wolfe

1 Like

I apologize… KB updated?

All I did was follow the integration and have the issues I’m having. It somewhat works, just not reliable as cameras are on when appear to be off and visa versa…

Regards,

Bill Wolfe

I have the Pro 2’s, so my experience isn’t the same.

I’d have to ‘guess’ that this may be by design perhaps? Arlo would have to advise about this possible feature on the Pro 3’s. Have you tried setting up an Automation to trigger a notification when motion is detected from the Arlo camera when this happens? If you get the notification, then the motion sensor is active. If so, I’d say that Arlo left the motion sensor enable so that it can be used while the camera is off. Probably because of the spotlight feature perhaps???

I’d say that it’s a problem on the Arlo side since all SmartThings can do it turn the Arlo cameras On/Off in the configuration scenario you provided, and since SmartThings can’t do anything to the Arlo Modes anymore. I’d try power cycling the Arlo base station to see if that stabilizes the experience.

I’ll try that. Thank you so much for trying to help me!

If they did leave the motion sensor active, that doesn’t explain why when I leave they don’t report motion at times though would it…?