Arlo Q SmartThings Mode not Appearing

Having recently resolved an issue with my Arlo Q camera’s firmware not updating (by swapping it for a new one!)… I have now ran into a new issue.

My previous camera automatically created a ‘SmartThings’ mode inside the Arlo app once it was integrated with ST. This is critical to arming/disarming the camera via ST,

However, this new camera will not create that mode. I noticed it once with the previous camera, but removing it from ST and re-integrating it make the mode appear. This time though, I’ve tried re-integrating about 20 times but I can’t get that mode to appear!

Has anyone else come across this? I haven’t found anyone who has experienced it on this form…


Hi Nick.
I left you a link over on the Arlo Community website for instructions how to set them up together.
Sorry, I forgot to paste the link over there and had to edit the post. Here ii is again.


Thanks for both your replies Brian.

Yep, that is the exact process I am performing. I’ve performed step 3 lots of times now (after removing the camera each time) to try and get the mode to appear in the Arlo app… but it isn’t doing.

@nick3young Are you trying from the phone app or through the IDE on your computer? The apps may be out of date. Verify that they are the latest version. Try on the computer. Have you changed passwords on either of your accounts?


The apps are both in-date. I’ve also tried removing the Arlo app and re-installing it from the Play store.

Do you mean trying from the IDE on the ST side of things? I haven’t actually been on and had a tinker in there at all yet. Do you think that might be worth trying then? I can give it a go when I get home and report back.

Log into both. That is where the action really takes place. Although you can change and install/delete things through the phone app, often changing your settings in the IDEs will work when the phone app doesn’t.
I am sorry you are having so many problems with the Arlo products. Usually everything is very easy to set up.
Keep us posted.


Oh blimey… I’ve logged into the ST IDE for the first time…

Ok, I’ve gone to ‘My Devices’ and ‘New Device’… is this what I should be doing? There’s a load of stuff in there I’m not quite sure about for adding the camera (e.g. Device Network ID). Is this what I should be doing?

Do you have an existing Smartthings with devices already in there? I am assuming you do.
Try clicking on that and see what happens.
Also log into your Arlo IDE. It also has a button for adding a device although that camera should be listed already.
Keep in touch as I try to research this a little bit.


I am assuming that the camera is not showing up in your Smartthing devices, correct?
At the top of the page, there is a button for adding a new device. Next to that on the right type Arlo Q Plus in the search box and then on the next page click on the Add device button and let me know if anything happens.


Are you using an apple iPhone or an Android phone?
I am not sure whether your support ticket is with Arlo or Smartthings, but be sure to place a ticket with Arlo support.


… the camera ‘was’ there. But I went flying in and deleted it (with the intention of re-adding it back in). I might need to add it back in using the ST app and this time, make a note of the settings before deleting it.

I use an Android phone (Galaxy S7). Yep, my ticket is with Arlo support.

One other thing, Does the name on your phone have any non alphanumeric characters in it?
Apple will name the phone Brian’s Phone. Arlo can have a fit with this. If it does, rename it so that it does not have any of these characters, (example Brian Phone).

I am surprised that no one else that own this camera and uses it with Smartthings hasn’t chimed in yet with some answers or suggestions.
I don’t own an Arlo Q Plus so bear with me if I ask some stupid questions. If the Camera does indeed show up in Smartthings, do you really need the Arlo Connect App for it to work?
Do some tests in Smartthings to see if it will detect motion and send you an alert and record videos.
Since the Arlo Qs work a little differently from the other cameras and are constantly streaming it seems to me that you might be able to just use Smartthings. You don’t need to Arm/Disarm the camera, right?
You might need to add the camera to one of your routines and use a custom rule to notify you if motion occurred. The videos would show up in the History section of the Smartthings app.
Just a thought.


I’m surprised too… and I’m surprised I can’t find anyone else with the issue (which makes me think it is an error I’m making!). Having said that, I have a new setup which I haven’t tinkered with and I don’t think there is a lot of room for error - I’ve followed the official guide to the letter. To add that, the camera which I returned integrated fine!

The only thing I need that ‘SmartThings’ mode for in the Arlo app is so I can automatically arm/disarm the camera (along with my other ST sensors) when I leave the house. Without that mode it won’t do it - it has to be manually set (or set on a schedule).

The Arlo app will send me alerts with motion… but the ST app won’t. All the ST app is allowing me to do currently is view the camera, change some settings (e.g. disable the microphone) and view the live stream. But I’d like to be able to auto arm/disarm the camera and receive push notifications from ST (not Arlo). This all worked fine on the camera I returned, ha!

I was wondering if I could somehow create the mode manually in the Arlo app after integrating with ST… but I’ve tried and that doesn’t work either. It obviously does something special to link it when it successfully creates the mode automatically.

Hope that all makes sense!

OK, That is a start.
Do you know how to create additional routines and custom rules?
We can test things that way. Later we can delete them and incorporate into SHM if we can get it to work. I don’t want to add it to SHM yet because I don’t want it to be sending you intrusion alerts at this time.

Briefly, add a new routine and call it Testing QPlus. Go through the various pages after hitting the little gear icon next to the routine name. I want to see if the routine can turn on the camera. You will be able to go to Things to see if the camera is active or not after running the routine. If this works we will continue.


OK… I’ve created two new routines: one to enable the camera and one to disable it. This works fine… the routines do indeed enable/disable the camera.

Only thing is… this is slightly different to changing the ‘mode’ of the camera. Disarming it keeps the live stream working but disables motion detection push notifications.

I feel I’m being a bit nitpicky… but I’d rather ‘disarm’ it as opposed to disabling the entire camera. And there’s no option under routines to disarm… only disable. Or were you heading somewhere else?

You are correct so far. The routine only Turns the camera on (standby Mode) and off, (Disarmed).Now do you know how to create a custom Rule? The rule is what starts the camera recording when it detects motion.

Go to the page that lists the name of your system followed by the words “Smart Home Monitor, (Should be your opening page.where it shows the three Alarm states).” Click on the little gear at the top right of the page.
On the next page it says Smart Home Monitor Configure at the top. Go down and click on the word Custom.
At the bottom of the page click on New monitoring rule.
On the next page where it says What kind of device do you want to use? Select Motion Sensor.
Below that where it says Select Motion Sensors see if your camera is listed.
At this point go to the next page. We can come back and configure this page for when you want to detect motion later. On the next page click on the little slider button by the side of Set up Text and Push Notifications. Put in your phone number and at the bottom put in your custom message.
(If you live in the UK or Europe this could be a problem but if you have been getting push notifications with your other devices or SHM put in how you did that before).
Select Done at the top of the page. This will take you back to the page you were at previously.
At the bottom of this page see if you can enter the name of your camera where it says Select Cameras.
Hit next at the top of the page. Click on the slider like before and above that give this Rule a name.
Do not forget to hit save at the top of the page.
Back out of this until you get back to your home page.
Go to the Routines Page and select the routine you just created.
Now walk in front of the camera and see if it detects motion and gives you a push and text notification.
Let me know if you have any problems with this.


If this works, we will create another Routine to turn the camera back to its Disarmed state.
At this point I only want you to know how to create and edit Routines and Rules. Later we will work on setting it up the way you want it to work.


Thanks for all that Brian! Are you a paid employee of SmartThings or just the world’s most helpful man?! Ha! Either way, thanks.

Right… before your post, I made a breakthrough. I created a ‘SmartThings’ mode inside the Arlo app (as I’ve done before). In the mode settings you have two names - one for the name of the mode and one for the name of the rule (a little strange in my opinion since you can only have a single rule inside the one mode anyway).

Now, I remembered from my previous camera that the name of the rule was a big long code. I just had a go at changing the rule name to the serial number of my Arlo camera… and jackpot, SHM is now sending me intrusion detections for motion on the camera! So to manually create the mode… it seems that the serial number must be the name of the rule.

It doesn’t make any real sense to me but it seems I got lucky and it works! I’ll keep an eye on it.

I feel a little guilty I didn’t discover this before your big post! But reading through it will still be of use to me as I continue to become familiar with SmartThings so it wasn’t written in vain.

And earlier you said sorry for me having so many problems with my Arlo. It’s honestly no problem. I’ve tinkered with enough ‘smart home’ kit over the last few years to appreciate it is never plain sailing. I still feel we are in the infancy of this technology but with the success of the Echo, Nest, Hue etc I can only imagine it’s up from here.

I have to say… I’ve been incredibly impressed with SmartThings. Unlike the Arlo it was as incredibly easy and smooth process to setup and, on the whole, it has been pretty reliable. Push/text notifications are instant and my phone as a presence sensor has been 100% reliable (along with the two dongle presence sensors that I own) touch wood I don’t jinx it now. My next step is to continue to test to the point where I’m confident enough to plus a 120db siren in!!

Anyway, I’ll keep an eye on the Arlo and report back in a few days. Thanks again for your help.

No, I am just a retired old man, bored to death and trying my best to help people get their Arlo systems integrated with Smartthings and help people learn about both systems. I really do love the Arlo/Smartthings integration. Surprised more people aren’t using them this way. So many problems I see on the Arlo forum could easily be solved with Smartthings.
I am very excited you finally got it going. Now your task is to write up how you got this to work on your original post on the Arlo Community website so that others don’t have to go through all this mess we have been through.


If i can be of further assistance just send me a message on either forum.


1 Like