Issues w/ Arlo & SmartThings


(Sean Murray) #1

I currently have Arlo integrated with SmartThings. The only thing I use it for is to enable or disable the cameras themselves. I do not want to use SmartThings to trigger recordings or notify me. I prefer to use the Arlo app for all of that. The issue I’m running into is that the SmartThings mode in the Arlo app keep changing the settings on its own. I tried editing the mode so that when motion is detected on any camera it will record video, but somehow the setting keeps getting changed back to “do nothing” when motion is detected. I even tried creating a custom mode and using that instead of the SmartThings mode, but it seems like the SmartThings app automatically switches the mode back to the SmartThings one.

Anyone have any ideas how to fix this? I like using the integration to enable and disable the cameras themselves, but not if I have to deal with this headache.


(R Scott) #2

Work around for me until the Smartthings Arlo integration gets fixed. Delete the Smartthings rule under the Arlo app Smartthings mode. Don’t add a new Smartthings rule, instead enable the existing Arlo rule by selecting arm mode in the Arlo app. Go into Smartthings Smart Home Monitor and create a custom monitoring rule to start recording on motion, etc. You can also use routines to turn on/off the Cameras.


#3

Some recent changes on how ST & Arlo work together has caused my rules to not work well anymore. ST keeps changing and overwriting the settings in Arlo so I have a work around that works for me. I created a new mode on Arlo called Smarterthings and set everything the way I want it. I then activated that mode in Arlo. Now ST can still turn on and off the cameras, record video and use the motion sensors as it needs to but is unable to change the settings anymore. Has been working this way for almost 2 weeks perfectly. No need to uninstall anything or change a single setting in ST. I even got to test the alarm function recording when I opened the garage door accidentally one night this week after it was armed. Nothing like multiple videos of me running through the house to turn off the siren in my jammies.


(kelvin) #4

Created and renamed the mode in Arlo app, however, somehow ST still catches it and revert on the settings to motion + audio detect, and do nothing

Seems like there’s a thread on the netgear side too, but they point to problem back to smart things…

Tried several methods in ST, but nothing would just record on motion without arming. Some capture video API is also gone, so I can’t get Core to work neither.


(Slimshizn) #5

This issue is known by SmartThings, you can be added to their list of people to contact once it’s been fixed. It’s been months since they said they were fixing it so I honestly think that they aren’t even trying. Best thing to do is delete the custom smartthings setup in arlo and choose “armed” instead. Then set up a custom monitor on the smartthings app. This is crap because it doesn’t actually come up as a normal alert like the smartthings monitor would, but works for now.

Edit: and it seems to drain battery faster.


(kelvin) #6

Thanks slimshizn! Yes I just deleted the mode and using ARM mode right now in Arlo :expressionless:


#7

That’s an understatement. I went from around 4-5 month charge time to 2-3 DAYS! Plus any commands sent from SmartThings causes a reset of my Arlo settings! Totally worthless!


(Slimshizn) #8

I agree, It’s to the point where I’m putting a latter against my tree it seems like every other week to charge the thing. This has to be fixed and its Netgear that’s dragging it’s feet. I’m probably going to just sell the damn things and use the Blink camera’s. At least they are getting good reviews AND have a DH on here you can install. ( All for cheaper ).


(Kmugh) #9

Bajeezus.

My cameras have been requiring a recharge every month now, and the rules were resetting every couple of days - like the backyard camera capturing a video when there is motion at the front door.
I assumed its the Arlo app till I saw this thread.

I also just called Netgear support, and they claim its a SmartThings issue.


(Mike Steadman) #10

same here - like many, the rules were overwritten a few times earlier in the year, then a patch was released and the problem went away, but over the past week this has started again and it has not stopped- called arlo support today and they didn’t seem to notice that this was a recent/known issue- the only solution is unfortunately to kill the integration and wait for an update - neither ST nor ARLO support is acknowledging this as a known issue at this time- spent 30 min on phone today and the ARLO support guy built a new mode and set up rules and told me to call back if it changed… it changed before we hung up the phone… I give up.


(Colfax Upton) #11

Put me in this same camp - all of a sudden Arlo notifications like crazy and no recordings.