Arlo Pro 2 Camera going offline

I’ve been having this issue for about a month or two now. My Arlo Pro cameras go offline in Smartthings but the Cam’s all work fine in the Arlo app. I delete all the Cam and base station and reinstall everything works for a few days then the same cycle all over again. Any fixes on the horizon for this? Anyone else having the same issue?

1 Like

I wish I could help but I have a similar problem. Cameras were just going offline. I just deleted everything but the arlo connect smartapp won’t install. It allowed me to login to Arlo but it won’t open to let me choose the cameras “…can’t open your screen right now” and there is no Smartthings mode created. I also cannot remove (uninstall) it because it won’t open.


I have also been having the same issues without any resolution. The Arlo Smartthings integration was week at best but now seems completely broken.

Here’s a fix I found. Go to the Classic smartthings app. Go to one of the Arlo camera on that page hit the refresh button, looks like a arrow in a circular motion. And boom camera started working in the new and classic smartthings app. Do this for every Arlo Camera.

I’ll give that a try, thank you. They push the new app so hard and still people are forced to return to the classic app to get things to work. Not good Samsung, that kind of thing proves the new app is not ready.

My workaround fix is very similar, but using the new SmartThings Connect app instead. What I do is go into the new SmartThings app Connected Services, select Arlo (Connect) , and then simply tap ‘Done’. This seems to reset things and all of my Arlo Camera’s and base station come back online in SmartThings. But, doing this also resets the Arlo Q to SmartThings Mode, and sets the Arlo Base Station to Disarmed in Arlo’s app. So, I just change both the Arlo Q and Arlo Base Station back to Armed in the Arlo app. I then have to power cycle the Arlo Base Station which will keep it in Armed mode, otherwise SmartThings will keep resetting it back to Disarmed.

In the new app, tap the hamburger icon, settings gear icon on the top right and scroll down to linked servicesand tap it. Tap on the arlo service and the arlo connect to link them.