Arlo integration not working

Trying to add Arlo to smarting app but keep receiving this error.

{“error”:true,“type”:“java.lang.NullPointerException”,“message”:“An unexpected error occurred.”}

Any ideas?

Jason

Same here. Cameras went offline for a day (works in arlo app) removed and tried to add again and getting an exception after authenticating:

{“error”:true,“type”:“java.lang.NullPointerException”,“message”:“An unexpected error occurred.”}

In the connect arlo smart app logs says:

regenerateAccessTokenFromRefreshToken “Pending”

Same issue @SamsungZell @erickv

Same here.
{“error”:true,“type”:“java.lang.NullPointerException”,“message”:“An unexpected error occurred.”}

Just checked mine and have no issues, but haven’t tried removing and re-sending.

It looks like there is an issue with the Arlo integration. I have a ticket submitted and sent them screenshots. Also, Arlo is also looking into it from their side. This was posted on their site…
“The Arlo development team is currently investigating this issue. We will provide an update as soon as we have more information to share with the community.”

Hello, everyone

Thank you for letting us know about this issue. I’ll proceed to share these logs with our development team.

Also, it would be very helpful if you could share with us some screenshots or a short videoclip showing the error message being triggered.

Thanks in advance,
Erick.

This is what I get when I try to connect to the Arlo service…

Google Photos

Ignore the TP-Link. That’s the other service that’s in the background.

1 Like

Ok, this is on iOS.

1 Like

When trying to connect , I get the error “Something went wrong.Please try to install the SmartApp; again.” I cannot even delete the connection. It gives the same error.

Arlo connected service in SmartThings won’t open. All of my Arlo Pro 2 cameras including the base station siren offline, but my Arlo Q+ camera is online.

Although, the Scenes that my Automations run to put SmartThings in Armed Stay and Disarmed are actually still turning the Arlo Pro 2 cameras on and off since I checked them in the Arlo app after toggling SmartThings Home Monitor into Armed Stay and Disarmed and they are actually going on and off in Arlo’s app.

1 Like

Same issue. All Arlo devices went offline for a day, except 1 camera. Removed 1 of the offline camera and tried to add it back, but Arlo (connect) return the same error message or tells me there is a network or network error.

1 Like

Hi and thank you to everyone that took the time to share some material to document this issue properly.

In addition to what @Paul_DeFeo has shared with us (go to his post), our team is working with Arlo to bring a solution to this issue as soon as possible.

Best Regards,
Erick.

Thanks @erickv

1 Like

A hotfix was just released from the ST side to address these issues.

Please let us know or contact support@smartthings.com if you are still seeing issues.

3 Likes

Worked!! Thanks!
image|231x500

1 Like

Worked for me too. Thanks so much.

Working now.
Thanks!

I’m from uk and working for me.

Working for me also. Thanks!

1 Like