App migration issues (region problems)

Hey there. I’ve had countless problems with migration to the new app, but for now I’ll limit the scope to the most recent.

When I moved to the new app and tried to add my wife back into the house, it told me we were different regions. Somehow, the migration changed my region from USA to India. I contacted ST support, was told only Samsung could change my region. Did that successfully (I can see in my ST account I am USA). But it still gives me the region error. I tried making a completely new account for her, same issue. Any ideas what I can do here?

Is there a way for me to dissociate my current account from the location/hub and create a new account for myself and associate it with my the location/hub without losing all my devices, custom handlers, automations, rooms, etc…?


I fell into the same trap.
I am in France but back in August 2014 when I started with SmartThings, I was attached to the US only cloud.
The SmartThings Classic App was working fine (with v1 Hubs) up to now, then I did the mistake of upgrading it to v2.20.1 (1204988) on iOS.
Now I cannot use the SmartThings Classic App, with an obnoxious pop-up message which masks the Dashboard and cannot be closed, and I cannot either migrate to the new Samsung SmartThings App because of region problems.

Bottom line : I end up with a $2000 pile of worthless SmartThings hardware.

A great way to reward early adopters, the ones who helped SmartThings to stay afloat :rage: :rage: :rage: