App Does Not Work!

So Samsung stopped the classic app that we were entirely happy with for years from working and forced this new thing on us. Well this “Update” does not work on any of our devices at all.
When we attempt to launch this"Update" all it does is crash and give up the dreaded, app has crashed , report or close screen.
Any suggestions would be appreciated since around 3k of no longer smart product no longer works from our devices.

1 Like

Hey there! @don544

If you are using an Andriod 7.0 or Higher Device and running the latest available version of SmartThings v1.7.56.21, Have you already tried clearing the cache of the Smartthings Application?

Settings>Apps>Smartthings>Storage>Clear Cache and restart your device?

After uninstalling and reinstalling the application does the symptom persist?

^SamsungZell

I am not running anything because the app you forced on me does nothing but crash when started. As your company decided to abandon my preferred working without a problem app I uninstalled it and installed the thing that is rated one of the poorest apps on the play store. Your so-called newer better app that currently scores a 2.8 and is called Samsung Smart Home.

If there is such a thing as “SmartThings” the play store no longer lists it and I would gladly return to the old working app that was called that but your company shut it off.

The app on play store is listed as Version3.1072.19.218 updated on OCT 7.2020 if the version you are speaking of exists in Play store I am unable to locate such an app using google play search.

The app has been uninstalled and reinstalled several times and my cache in my Samsung Galaxy phone has been cleared before each reinstall.

The only thing the app does is crash and I report it each time with increasingly caustic comments

look for the app with the following icon:

So thanks to Samsung for apparently making all my smart home devices useless with my phone even though they were working great until now. Accessing the play store via Windows and the internet google says your updated app no longer works on the phone I have always used since I bought the hub and the sensors and the three TV’s and the refrigerator and the dishwasher and the blueray and it seems Samsung no longer wants us as customers.
SInce I attempted to access the app origanly from the phone itself that would explain why it no longer appears in search.
It appears it is goodbye to Samsung .

many of my lights no longer work with the new app and when I try to delete them to re-add it just spins. I can’t find the repair option any more either.

the old app barely worked but it worked better than the new one. I don’t know why I’m still here.

samsung is so bad at software

I am similarly frustrated with SmartThings. They have dropped support for a number of cameras including ironically the Samsung Smartcam ones and even D-Link, which is probably just about the most well-known camera manufacturer. Then they force people onto yet another new and “improved” app which won’t work on anything earlier than Android 7. This is about the third (or is it fourth?) attempt at developing a workable app. I am using a Lenovo P2 which has been similarly left behind by Lenovo in the UK (not in India which got Android 7). Because my home contains “unsupported” (read - was supported but not any more) devices I can’t even migrate to the new app, even if it worked on my device, which the earlier rewrite did but the new one apparently doesn’t. So, I can’t even remotely unlock my front door using the app, I can’t monitor my home using their own web cams which were previously marketed as being SmartThings compatible and I can’t change the temperature on my thermostats remotely since the only interface they had (despite promising a web interface 8 years ago) no longer works. In short, I can do more with my £25 Echo Dots than I can do with this pile of junk. They said I could keep on using the “classic” (read: actually slightly working) app instead but neglected to mention that they were going to shut it down totally in the very near future anyway. What sort of way is that to treat their customers? Having said that, their “SmartCams” regularly disconnected from SmartThings anyway - which makes this whole system useless to me for security monitoring. Permanently streaming 30 seconds of video was a killer feature, but if there is another solution which can do this, then I am definitely leaving Samsung - from the Hubitat forums, it appears many users are Smartthings orphans. I am thinking whatever will Samsung drop support for next; much of the work that has been done to support the platform has been done by 3rd party developers for no recompense - this is really some way to kick the community in the teeth to then withdraw support for many of the device handlers and apps that they’ve developed.

I received a hubitat for Christmas so I’m now planning the migration of 62 devices. It is a daunting task, but I’m hopeful that the grass is greener over there.

100% agree that forcing a higher spec device to control Smartthings was a poor move from Samsung to say the least

That said there is a way to regain (some) control of your devices BUT no control for automation editing

There is an app called ‘Home remote’ available in the Android store and probably the Apple app store

Once installed, you can connect it to your smartthings account from within its settings and (most) of your devices will become available to control and or read

The ‘Home remote’ app has no built in automations or access to created smartthings automations, it simply displays devices and allows on off control

I agree this is a poor way of controlling Samsung products but at the moment I see no other app that can help

Hope it helps in some small way

Just to note, the ‘Home remote’ app does have a pro version that allows the user to create there own look to the app via a Microsoft desktop application, IP cameras are also supported within the app, might be a good way to control ST on a tablet that is wall mounted but now is no longer capable of displaying the new app

It is a daunting task. However as Samsung is abandoning us I see no choice in the matter.
Remember they left us not we left them.

Check out the Hubitat at https://hubitat.com/
A little more difficult to use and set up , however you are in control and it runs out of your home not Samthugs servers.

I am not going out to buy new devices to make products that worked fine until Samthug screwed it up work.
I have a Hubitat and will finish migrating to that as they abandoned us.

That app is not sanctioned for older samthug phones so play store does not even show it when you search from a device. When play store is searched from windows the app shows as greyed out for all of our phones as not not compatible with our devices.
You misunderstand , we know it is there but not unless we drop another2 grand on new phones. No Thanks.

Well at least some of it works for you.
App is not compatible with any of our phones.

They talk a good game and one would think they would care about their brand image, apparently not.
Spread the word, I know I am.

So using a Samsung s20 5g latest and greatest wiz bang and the app just crashing at launch.
Using an S10 , app just crashing at launch.
For giggles installed on blue stacks using every mode available with every device profile available and all the app does is crash.

To SamsungZell
So using a Samsung s20 5g latest and greatest wiz bang and the app just crashing at launch.
Using an S10 , app just crashing at launch.
For giggles installed on blue stacks using every mode available with every device profile available and all the app does is crash.

I agree, the new version of the app sucks.
Samsung has been disappointing me more and more lately. Not long ago, I had a problem that I couldn’t turn on youtube on TV, and I wrote to the support team to help and received ZERO help. How can you want people to buy and use your production when you are so indifferent to them.
I don’t even mention the application. I want to launch it, and it crashes. All they have to do is take out apps that pay you to play games, and that’s it. What else do they have to do

Still crashing with S10 for me.

Do you have a support ticket I can reference?