Anyway to put a sleep timer on Nest Thermostat?

i think the timer is not working

Which tab of the timer app you are not seeing the nest?
The first tab is for the switch, not the thermostat.
You will only see the nest in the second tab which mark choose thermostat.
If you see the nest in things, you will see the nest in the second tab.

Yes in the second tab yes , but I did one test to turn off in 2 minutes but didn’t work

Ok and whay should show me in the first tab? I need set up something there because is showing me my tv

The first tab is not the thermostat, All these are part of the setup. If you did not set them up correctly, nothing will work.
What is the switch you pick for the first tab?
Was you able turn on the air conditioning with the switch you pick?

You need to take a little time to get a handle on exactly what you are doing.

This should help you big time!

No ,I’m not able to turn on, how i choose the switch ?

You will need to create a virtual switch. Go to web, go to my device, + new device, in new device, fill in the field, in the type field pick the simulated switch. This will be the switch you turn on and off the timer.
Go back to the timer app, pick the switch you just created as the switch.
One more thing you may need to configure. Go to the nest app (not the smartthing one), turn the mode to Cool (at the bottom) in summer, turn the mode to heat in winter. Don’t pick the Heat+Cool. This will confuse the app and it does not know whether to turn on heater or air conditioner. I will need to see how to improve it in the future.

What I should put in Device Network Id *?

Put any number will be fine, just not to conflict with other device you have. I usually use 1000, 1001 etc.

I don’t have any option in location , and don’t allow me create without location

You need to select location first. Go to web page, My locations and pick the location first.

I got tks now the only thing is I can’t find how to change the settings in nest app I’m working on this now

I couldn’t found how change in nest but everything else is set up ,but the timer still not working

See picture below

click on the mode in the bottom

select cool in the menu

I Just have option cool

Ok, it should be good.

but the timer still not working

in thermostat timer I need oauth?

and the strange thing is that when I set up the timer, it shows off the swich after the time I put it to hang up but it does not turn off the AcC