Anybody using their Pebbles with ST?


(Ernie) #1

I was wondering if anybody is using their Pebbles for anything interesting with ST. Since I don’t have the skill to create Smartapps or Watch apps I have been making do with more mainstream methods. I have the SmartThings watch app which can change modes, toggle switches, provide switch status and toggle locks. Works good but I rarely need to use it. What I do use is PebbleTasker for specific tasks I want done. This is what I have so far:

  1. Dismiss an SHM alert. I only use SHM for alerts and not actual security. I find dismissing the alerts from the watch is a real time saver.

  2. Check doors and locks. I use @joshua_lyon’s Sharptools to get the status of my doors and locks, and then use Pushbullet to push a notification. I also use the Pebble MyTimeline app to record the notification in my timeline.

  3. Check temperature around the house. Used same procedure as #2.

Anybody else using their Pebbles with ST?


(Chrisb) #2

I used my Pebble, and now my Android Wear, to run Tasker tasks. This is pretty easy to do with Pebble Tasker and you can get pretty advanced with it if you want. SharpTools makes it easier too as you don’t have to setup endpoints or http calls.

I setup 3 virtual tiles in ST, and then tied those to three tasks in Tasker, which were the selected options in PebbleTasker.*

I think wrote some very simple SmartApps to do a specific thing when those virtual tiles turned on.

I setup routine tasks like unlocking my side door or turning on a plug for my laptop to those virtual tiles. It’s a great short cut for routine tasks cause you don’t even need to pull out your phone. A few quick taps or button pushes and you can do what you need to do.

(* You can of course just have the tasks interact directly with the device that you want to work with. The reason I did it this way was three fold:

1.) Flexibility… back when you had to do with with REST Endpoints it was a pain to change it you decided you wanted to do switch B instead of switch A… but if I use a virtual tile and a SmartApp, just a quick change in the SmartApp would make it work.

2.) Security… The app I wrote to unlock my side door was set to ONLY run if my car was home. That way if someone, somehow got the endpoint info they couldn’t open my door if I wasn’t home.

3.) Increased options… Because it a smart app I could have it do multiple things… turn off lights x, y, and z… turn on light a and b. Change modes, whatever…)


(Jordan Thurston) #3

I’m using mine, but not for anything groundbreaking. Mainly for dismissing alerts. And I also use the SmartThings Pebble app to change modes/toggle switches. But that’s about it. I would love to use it for more, but I just haven’t really found any other uses. And I’m on iOS, so unfortunately I can’t use Tasker.


(Darc Ranger) #4

I use the SmartThings Pebble App created by mongo527. This lets me change modes, toggle On/Off switches and trigger Momentary switches. It can also lock/unlock doors but I do not use that function. And like with all Pebble apps it needs to linked to my phone…


(Tim Gray) #5

I tried to, but their changes makes the pebble app unstable so I gave up. Just launched “dwelling” and it’s still broken and not useable.


(Ernie) #6

Are you talking about the SmartThings Pebble App created by mongo527? It can be a little slow to load up, but once populated it works fine for me.


(Tim Gray) #7

No I’m using the other one that is for the color pebble called “dwelling” it works for a while then ends up blank until you go in and reconfigure it again.

Don’t know if it’s SmartThings doing changes on the backend or if the pebble app is buggy.


(Hamx0r) #8

I’m looking for a guide to installing and using mongo527’s SmartThings Pebble app. Even reading the source code (https://github.com/mongo527/Pebble-SmartThings/tree/master/src), I can’t figure out how to get through the Setup flow (from within the iOS Pebble app.

I have the pebble app installed on my Pebble Steel (which is running Pebble Time flavored firmware v3.11.1), and I can open it to see a menu of Modes, Switches, Locks & Momentary, but if i select any of those (middle button), the resulting submenu is a completely blank screen.

On the phone side (iOS 9), I am trying the following in the Pebble iOS app:

  1. Click Apps (middle button on bottom)
  2. Click SmartThings app - it opens popup for Settings or Delete
  3. Click Settings to proceed through Authorization flow with my SmartThings.com account
  4. I enter email and password to successfully log in
  5. There’s a message about "Pebble will be able to…{do some stuff}…From: {drop down box}
  6. I select Home (the only item in the drop down box, then I see
  7. “Client is not associated with SmartApp in location Home”
  8. The Authorize button is grayed out. All i can do is click Deny or Cancel (up on top right of screen)

What is a Client in this context? The pebble App? The pebble itself? My phone? My SmartThings account? My SmartThings Hub?

Can someone add the missing details to get this working please?
Thanks!


#9

Open the Pebbles app on your iPhone
Select your (pebble) apps Tab then find the Smartthing App. Press Settings
You will probably need to log in.
Once logged in Select you hub and the devices you wish to access via Pebble
Authorize and Save

You can make changes to the list either with the Pebble app or the Pebbles SmartApp you installed with your Smarthings Mobile app (via Marketplace)


(Hamx0r) #10

Thanks @cdikland. When i get to your 4th line, the only selections I can make are from a dropdown called “From” and it is populated with the only Hub I have. Your instructions match what I did (steps 1-3 in my previous post). My step 4 is where I need help. What does “Client is not associated with SmartApp in location Home” mean?

Once logged into my smartthings account (your step 3), I also see the menu icon on the mobile web page. Clicking “hubs” (in Developer Tools section) it says “You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.” This is the same error i see, even when logged in, to: https:// graph.api.smartthings.com/hub/list (laptop or mobile browser)

However, if I click My Locations then go back to My Hubs, I can see my hub just fine and the URL changes to https:// graph-na02-useast1.api.smartthings.com/hub/show/

I can use my laptop browser to go through the same OAuth flow and if fails in the same way no matter which subdomain i use (graph vs graph-na02…). The below URL is what the Pebble app sourcecode uses
https://graph.api.smartthings.com/oauth/authorize?response_type=code&client_id=93299720-c3bc-436c-96bd-f0a7fdf1bc82&scope=app&redirect_uri=http://shawnconroyd.com/pebble/smartthings-callback

So the question remains: What is a “client” in this context, and how do I associate it with my “Home” hub?


(Hamx0r) #11

PS, I don’t see the Pebble SmartApp anywhere in the marketplace - perhaps it was removed? If not, what category is it under? (there should really be a search here)


#13

The pebbles app has not worked for me for sometime. If I get lucky it might turn on/off a switch but most times the switches dont even appear in the list, dont respond when pressed or simply hangs. In most cases the app gets disconnected from the account and it requires log in. Given its unreliability lately (used to work just fine) I gave up.


(JF) #14

The App has been pulled from the pebble store, I had always had good success with it, you just had to launch it twice every time for some reason. Today it simply disappeared from my watch and the pebble app. When I went to look for it in the pebble store it is nowhere to be found and neither is Dwelling which was an alternative.
Did Samsung pull the cord? Do they want us to use Artik? They have a pebble app and there is a smartapp for it in the marketplace on the Smartthings App but there are some severe warnings in there I don’t know much about and don’t want to screw anything up. At the end of the day, now I am missing the ability to control ST with my pebble!


#15

Same here Jefo! I had the same issue where you’d have to open it twice, but whatever, it was working. I don’t understand why it got removed from my Pebble just like that. Really frustrating :frowning: