Any of You still using the Fibaro KeyFob (with webCoRE?)?

I bought one of these recently. It seemed expensive, but with the thought of having 30 button functions in a single device, I decided to give it a try.

Unfortunately, I seem to only be able to get it to work on a single press of the 6 actual buttons, and none of the other stuff.

I’ve tried the default Z-Wave Multi Button, The ClassicGOD, and the ‘official’ handler from Fibaro.

Do you have it working on more than just a single click of the 6 actual, physical buttons?

Multiple keystrokes work fine for me. You have to press very quickly, otherwise they are considered as single several times.
I use Android app last version

I have opened a support ticket because in the automations the actions of the 6 buttons are shown all in a row, without showing which ones belong to each button.

Also, I don’t know since when, the automations that you carry out with the AND condition of 2 or more buttons are executed as OR. Any button you press in the combination triggers the automation.
This worked fine, since I had it done to control STHM.

Let’s see what they answer

Last night, I was so happy that I at least got all 6 buttons working for just a simple press on any one of them.

Now though, it has become intermittant at best, with maybe one out of every 10 or 20 button pushes actually doing anything at all.

Some of the presses show in webCoRE as having succeeded, but nothing happens to the lights. lol

Oh well. I guess I will send it back, and give up the dream of ‘one remote to rule them all’.

Which Device Handler are you using?

Z-Wave Multi Button original.
Did you do a zwave repair?
Everything works for me except the use of multiple buttons with AND conditions in automations.

I had a hard time catching the Timing of the button presses!
See if I can make a video

1 Like

I have been testing again and I see:
When it is inactive for a long time, it must be asleep and you have to do a long press to wake up, then it always works fine.

For “Hold push”, you have to press it as 1 sec, if you do it longer it interprets it as “pressed down” and when you release the button it sends a “Hold push”. This makes it difficult to use these two actions, they can be mixed.

This is a video with actions

No. Silly me. lol
Thank you for the reminder.

Another funny thing is that it seems like the working condition comes and goes throughout the day (like right now…even though I can clearly see that the KeyFob is doing something by the quick green blink when I press a button, nothing happens in the system), and I haven’t been able to pinpoint any sort of correlation with anything else. I wonder if it’s just going to sleep like you mentioned.

After running the Z-Wave Network Repair, no change. None of the button presses are doing anything other than blinking the KeyFob green light. Well…I mean, there is some signal getting through into SmartThings (I can see it when it hits the logs in webCoRE, and intermittently in ST Live Logging), but no successful automations.

Immediately after typing EDIT1 above, I went back and tried again, and this time, 3 of the 6 button presses (once on each after waiting for reaction) resulted in successful automations. I have always HATED intermittently successful automations. Do you think this is due to something goofy with the KeyFob, or what?

1 Like

Hahaha, it’s going to you crazy. :woozy_face:

Try training button presses like in the video I uploaded:

  • Open the details of the remote control in the app.

  • Make a short press, it lights up yellow and “Pushed” comes out.

  • Press 2 times very fast and show “Pushed two times”

  • Press 3 times very fast and show “Pushed 3 times”

  • Press and hold the button and it displays “Switched down”. Release the button and it displays “Held pushed”

  • Press the button for about 1 sec. and shows “Held pushed”. This is hard to come by.

They come out in Spanish for me and I don’t know what the exact translation that comes out in your app will be like.

The green led on the remote turns on when the capture of the pulse sequence ends and the event is sent. If the sequence is not done well it does not send anything.

It was difficult for me to get the timing of it, then it goes well.

I tried the quick controls and they identify well each button and action.

It is entertaining :smile:

1 Like

This is my version of keyfob, to see if yours, being more modern, has different firmware. My fingerprint matches the European version of the dth.

Are the values to be captured in webcore the ones shown in IDE?

For your information, I have received a response to the support team, about the problem that the actions are shown in the automations without indicating to which button each one action.
Reported our Engineering Team for further review and resolution. Hopefully, they will implement a hotfix if required.”

About the AND condition fails in automations they have not said anything.

I really appreciate your willingness to walk through some of this with me.

OK…I went through all of that to test it to see whether SmartThings is even seeing the button presses, etc, and it is indeed seeing all of them.

However, only some of the related automations I’ve created in webCoRE are working.

Part of the problem is that I’m trying to use this KeyFob to turn lights on and off, etc in Alexa.

Since there is no native integration, and since Alexa can only react to sensor activities in SmartThings, I had to create a set of simulated contact sensors in SmartThings to represent each of the buttons (I’ve only done the main 6 so far) on the KeyFob.

Then I created Pistons in webCoRE (one each) to ‘translate’ button presses to simulated contact sensor actions.

Most of this is working, but now I have another problem (which may require a separate thread to ask for assistance with that)… Two of the simulated contact sensors are showing up as “Checking…” within the SmartThings mobile app, and they are the ones that aren’t working.

I deleted and then recreated one of them (AND went through all of the steps to make sure it is available in webCoRE AND Alexa), but the new one still says the same thing (“Checking…”) in the SmartThings mobile app, and is also not working in either webCoRE or Alexa.

1 Like

I can’t contribute anything about webCore, I don’t even want to try it, I’m sure was going to love it and I’d be doing pistons all day, hahaha. :rofl:
As long as I can do everything I need with automation and smart apps, I don’t want any more trouble.

See if you get it and it works fine!

1 Like

I did reply seeking more information about the use case for this, since usually on a Remote only one button at at time can report “Pressed” (or “Held,” “Double Pressed,” etc). It seems like that part of my response was not sent to you.

This is new feedback for me, totally willing to report this portion (already reported the missing “Button” component labels as Fiona mentioned to you). I didn’t really understand very well the use case for this or if it would actually work as expected.

Feel free to PM me to continue that conversation.

1 Like

Thanks for the reply.

Indeed that part did not recived in the reply email.

True, if you press more than one button exactly at the same time or hold down one and press another, it does not send an event.

I will send you a PM with the information of what happens