Android users, any new app issues right now displaying devices (Mar-1-2020)?

Any Android users out there having the app just blink or show a blank white screen when tapping on a device to try and open it? This is happening to me right now. Of course, the Classic app works perfectly.

Happens on my Note 5, an old S4, and my Galaxy Tablet.

Not here, S10+ Android 10

Are you on version 1.7.44-21 yet?

Yes… 10 or more chars

1 Like

Thanks Bob. ST support wants me to uninstall the app from all 3 of my devices and try again. I’m not really going to do that since it was working just fine a couple hours ago and now all 3 devices won’t work with the new app. Very frustrating. I think I’ll just stick with the new app for a while longer.

I’ve been messing around a lot with device metadata today, but I’ve certainly noticed blank white screens rather a lot. Sometimes they do eventually populate. The other times I give up as it takes so long.

Not relevant to the original question, but the STHM server error is becoming more frequent, and the latest curiosity is that when I go to add devices I no longer get the near immediate display of brands/types to choose from. Instead the system displays ‘searching’ for rather too long. Maybe it has always done that, but if so it was very quick and I didn’t notice.

Are you using the phones as presence? You may be able to just clear the cache. Or have you closed your apps and restarted the phones? Strange that you would experience the same on multiple devices.

You know better than to listen to them. LOL. I am surprised they didn’t tell you to reset your hub. LOL


LOL, very true. I’ve been exchanging emails and direct messages to them as I write this post. They haven’t mentioned it (yet), but they did ask for screenshot and a few other things.

All devices in the new app show as offline for me now, but my hub is fine and the Classic app is performing like a champ.

LMAO, so they just blamed this on a custom DTH, which the device isn’t using, so I had to show them how to double check which handler a device was using. And then I showed them a device running their stock handler doing the same thing. I have a feeling this will be my entertainment for the evening…


That is exactly what I had on a couple devices. The one I remember was an Aeon Energy monitor. Changing the device handler fixed it.

I had something else that did similar and I just edited the device,changed nothing and saved and it worked. I do not remember what it was :slight_smile:

1 Like