No Devices Classic App (Something's Wrong We Can't Load Your Screen)

Since last night I’ve had an issue on the Classic app where my Things won’t show up on the Dashboard screen under favorites or the My Home section under Things. I get the error “Something’s Wrong. We Can’t Load Your Screen Right Now.” If I go to Rooms, I still see my devices there and I also can still see and control all my devices in the new app. It appears all my automations are still functioning, but I have no manual control as my devices aren’t loading on the main pages.

Also in IDE i’m getting an error when I go to the My Devices tab:

Oh No! Something Went Wrong!

500: Internal Server Error
Reference Id
Wed Jul 01 12:36:28 UTC 2020

@Brad_ST maybe you can help me out? Please?

Thanks in advance to all attempting to assist!

Have you tried logging out of the app and logging back in?

Sorry, I should’ve stated all my troubleshooting steps in the original post.

Yes, I’ve tried to sign out and back in. I’ve tried to delete the app and re-install. I’ve tried to use a different computer to log into IDE. I keep getting the same error each time.

Have you contacted ST support?

No, I was trying to avoid that judging by my last experience with them. It took 3 days of emails back and forth and they kept asking questions unrelated to the problem. If that’s the only option, then I can, but I’d like to avoid it if I can.

Well I put in a ticket but I really kind of need help more urgently since myself or my family can’t control any devices from the app since they don’t show up under the device list.

I can figure it out, but the rest of my family is not as technologically adept and showing them a completely new way to do things is not gonna fly right now. Especially since there doesn’t even appear to be a way to have favorites set on the new app like there is in the Classic app.

I’m hoping someone from the ST staff on here can help. I know it’s a holiday week but I’m hopeful!

Please… @SmartThings @blake.arnold @jody.albritton @Brad_ST @garrett.kranz @BarryA

Most of the people you tagged do not have access to the support tools needed to address your issue. Please open a request with support

Thanks, I have and the only response I received back from them so far is a generic request for iOS version information, etc. Judging by my last experience I’m sure we’ll go back and forth about the same thing a few times but I hope to be wrong.

Anyway, thanks for commenting and letting me know. If you know anyone that does have access to the support tools needed to fix it, it would be nice if you could pass it on. If not, I understand.

It should be known though, that trying to get support to fix a problem is a lot more difficult than it should be. Especially when you provide them all the information up front and they still don’t understand and ask for non-essential or unrelated information.

I understand the process though, and know that you aren’t tech support. I just wanted to throw it out there though.

how are you getting to the IDE? Are you using

You should be all set. There was a Zooz outlet device record that was corrupt and had to be deleted.

Fwiw, it wasn’t a syncing issue or this - No Hub In Your Current Location (New App)

1 Like

Thanks @Brad_ST ! I figured it was that Zooz device as I noticed it was there in error and was trying to delete it but it kept erroring out on me.

I definitely appreciate the help and thank you again!


Not sure if this is related but I have had similar errors today with the new ST app. It would not load the STHM with just server error stated. I emailed support but with no response I decided to try and fix myself. I deleted from IDE and app and reinstalled … fixed until I notices a lot of my devices disappeared … and then I noticed in the IDE a number of devices lost their hub assignment. Not sure what on earth ST are doing but they need to get their act together as not impress if i have to re-install all those devices … So much for new app …improved stability !!