SmartThings Community

Android Smartthings classic slow notifications

(JIm) #42

What I find a little puzzling, is that other apps on my phone have push notifications that are still instantaneous. It’s only ST that is slow. So if it is due to Doze then why aren’t all apps affected?

(JIm) #43

After doing a little more research, it appears that an app can be written to ignore the Doze mode to receive instant notifications. So that again puts it back on ST’s shoulders to write the app with that in mind. Course maybe ST figures none of their notifications are that important…

(Michael) #44

My experience has been that most of my apps were receiving slow notifications since updating. I had maybe a couple apps that were not affected; even my GMail app was receiving slow notifications. Also, i’m using an Android One phone, so running stock Android. Disabling Doze has fixed all notifications.

(JIm) #45

Your experience is different from mine.

If you google the Doze issue there are a couple web sites for developers that specifically spell out the commands to have an app ignore the Doze feature, which provides immediate response. So ST can make that happen. And a lot of my apps apparently have done so as I get very timely notifications.

The other problem with disabling Doze completely is battery life. I don’t want to disable it for everything as that would run the battery down. Doze is there for a purpose and it does that very well. And with a programming option to ignore it within an app, that is what needs to be done.

(Tristyn Russelo) #46

Thanks for this. That (above) will be my next step, if needed.

So far it looks like the ADB instructions from this post are working for me.

disabling (whitelisting) single app from doze.
not disabling doze altogether.
stays after reboot, but not after OTA updates.

in the thread posted, it mentions going into a menu and selecting “not optimized”
These instructions did NOT work for me.
The ADB instructions below do appear to be working.

adb devices
adb shell dumpsys deviceidle whitelist

My device is an NON-rooted Essential PH-1

(Tristyn Russelo) #47

After a few days i can say my experience has been SO MUCH better with this even after rebooting phone.

(Mr Garry Plowman) #48

Great thread and brilliant to find a true fix for this most frustrating problem!

I found the SmartThings Classic App requires a different package adding to the white list. This worked for me;

adb shell dumpsys deviceidle whitelist

If the command was successful you should see the output;


After performing a restart run this command to ensure the listing is still present;

dumpsys deviceidle whitelist

Hope this helps! :wink:

(Derrick) #49

I am having the same problems with ST pushing the notifications to me when they are triggered. I have tried deleting, adding the app, playing with the notifications, nothing was working. I then set up the “additionally, also send a text message” option with my phone number. Later that evening, a few doors had been opened, the text messages came through immediately. The notifications came much later, not acceptable. I may just set all my notifications to send me a text and turn off the push notifications till they have a fix. Hope this helps someone.