SmartThings Community

Android Smartthings classic slow notifications


(Robert) #21

I’m using a GS8 which is on Android version 8.0.


(Frank ) #22

It’s Android Pie and it does it with ST and other apps. About the only thing that isn’t notification throttled are Google Apps, Text Messaging, and other carrier based stuff. Makes me mad.


(Vick Sarkis) #23

If that’s the case then Google really needs to get their act together and fix this.
Made my ST useless.
Thanks for sharing.


(Benji) #24

I’m on an SGS6 with Android 7 and my notifications have slowed way down for SmartThings Classic.

I thought it was just me but apparently not?


(JIm) #25

Doing some experimenting.

I had notifications turned off on the Classic app and Turned on in the Connect app. IF both are on, when it works, I would get 2 notifications, 1 from each app.

So I turned them back on for the Classic app. They started working. After about a day, I turned the Classic app back off. They are still working, although it has only been a couple days and I don’t get that many notifications.

On my wife’s phone I had the same configuration, Classic off, Connect on. I opened both apps, she never looks at them and thus they hadn’t been opened in a while, and the notifications started working again. I didn’t change the notification on/off option just opened the apps. Again, only a couple days. Will see what happens over time.

Not sure any of this helps anyone, but just some observations.


(JIm) #26

Well, it didn’t last. The push notifications quit working again. I got a couple days out of them.

I used to think this was an Android issue, but after further evaluation not any more. I have other apps that give me push notifications that work flawlessly. For example, I have a gizmo on my car that sends me a notification whenever the car moves or stops. It has been 100% reliable and comes in within about 15 secs of the car moving. And I haven’t opened that app in weeks. No need to. Also have a credit card app that notifies me when my card is used. It is so timely most of the time I get the notification before I get the receipt signed at the cash register. And again I haven’t opened that app in weeks.

So it’s not a matter of having to open an app occasionally. It’s something in the way ST handles it. I wish someone from ST would chime in here with some info.


#27

Is this 100% reliable information what you are saying or just a good guess? If this is true then it has nothing to do with smartthings and we should probably ask help from somewhere else.


(JIm) #28

I’d say it wasn’t true. I have apps that have no connection to Google at all and they work fine.

Not only that, but I’m still on Android 8 and ST notifications don’t work. So I still say it’s an ST problem.


(Vick Sarkis) #29

I’m going to have to agree that this is more of a ST issue rather then Android OS.
I have adt pulse and if my alarm goes off I get notifications.
Yesterday my alarm was set off by accident and I got a push notification from Adt app instantly. Also I had not opened the adt app in weeks.
I’m more leaning towards ST then Android os.


(Steve Perry) #30

I feel like this has to be an Android thing. We both have Pixel phones and seems like this has been going on since around the time we got Pie.

When I unlock our Yale door locks I get the ST notification anywhere between 2-20 minutes later (used to be 10-15 seconds) or when I turn on the display.

We also have an iPad in the house (iOS 12) which still gets the notifications almost immediately.


(Steve Perry) #31

It’s this setting in Pie: Settings, Battery, Adaptive Battery, Use Adaptive Battery

Mine was on. When I turned it off I started getting ST lock notifications within a few seconds.

The info text for this feature says “To extend battery life, Adaptive Battery limits battery for infrequently used apps. Your phone will learn how you use apps over time. Notifications may be delayed for these apps.


(Vick Sarkis) #32

I just conducted a small test and here are the results.
My primary device (which is having this issue) is a Samsung Galaxy S9 android version 8.0
Test Device LG G Stylo android version 6.0

So i installed SmartThings on both devices and let them sit idle for about 20 min. I then activated a sensor and the LG G Stylo sounded the notification instantly(like 1 second after the trigger) My galaxy s9 did not make a sound and no notification until I turned on the screen after waiting for about 3 minutes.
I did this test a few times to make sure and got the same results every single time. LG is instant notification where the samsung is delayed anywhere from a few min to hours.
This leads me to believe its not smartthings app issue, its more like an android version issue. I tried the whole battery saver options but that did nothing for my galaxy s9.
At this point i dont know what else to test or try.


(Tristyn Russelo) #33

I have an Essential phone on android Pie.
ST classic - slow sometimes 10-60 minutes. rarely instant
“new” smartthings - instant

I have tried:
turning off battery optimization settings in android pie

Settings > Apps & Notifications > Advanced > Special App Access > Battery Optimization > DROPDOWN MENU ( Not Optimized change to All Apps ) > Smartthings (any geo location app or photo upload app) > Don’t Optimize
And
Settings >Battery > Adaptive Battery > off

IT HAS NOT HELPED ST CLASSIC.
it DID help google photos uploading.


(JIm) #34

My phone is also an LG. And the notifications from ST don’t work correctly.

It may very well be an Android problem, I am on V8 by the way, but it seems that other apps have solved it if it is. I get push notifications from other apps with no issues.

So if it is an Android change then there is something that ST has to fix which makes it their problem.


(Solutionssquad) #36

I am also having this issue.
Sometimes ill get 20 notifications in a row.
It feels like an optimization, however I have disabled it for the app.

Running Android 8 on an LG V2O


(JIm) #37

Had an interesting observation. If you have notifications enabled for both apps, classic and connect, then anything set up in the classic app or a smartapp will give 2 notifications. When they are working that is. And that is to be expected.

If you set up an automation in the new app that has a notification you only get 1 notification, not 2.

To claifiy, I mean push notifications.


(Vick Sarkis) #38

i think @this point enough people have chimed in with different devices that it is close to being an ST app issue with in regards to android OS version 8. Like i said in a previous post, i installed ST app on a very old LG phone that is running android OS 6 and notifications are instant, not even a 2 second delay. I was about to go change my s9 with an lg g7 thinkq but i think for now i will hold off and see what others are saying and if anyone finds a solution besides waiting for ST to some day update the app. But to be honest i wont hold out hope for this, they might be just pushing people to use their new app.
Question…
has anyone here that was experiencing this issue swapped to only using the new app and had this problem resolved? if so please share. I will be today uninstalling the old ST app and doing a clean install on the new one to see if that solves the issue, I will report back here with the findings.


(Vick Sarkis) #39

I have found what looks like a solution for me getting notifications.
I deleted the old ST app and installed the new ST app, i re setup notifications for whatever contacts i wanted and so far for the past few hours i get them almost instantly, maybe a 2 second delay.
I dont know if this will work for other people or not but i guess its worth a try if your having similar issues.


#40

I agree with this, I’ve been using iOS for many years and the ST push was pretty close to instantaneous as you can get. I finally got fed up with Apple protectionist ways and ditched my iPhone and got a Galaxy S9+. The notifications for ALL apps are slow and ST is slow for both versions of the app. My iOS devices still get quick pushes though.


(Michael) #41

I started experiencing slow notifications with the SmartThing Classic app; usually 10-20 minutes late. I noticed that it was after an Android OS update. So, I did some digging and found that in the latest versions of Android 8(oreo)/9(pie) Google has really been changing the power optimization and started really using the Android Doze (https://developer.android.com/training/monitoring-device-state/doze-standby) feature (though available since Android 6).

I found some articles (https://forums.androidcentral.com/android-pie/904647-notifications-delayed-stopped.html) with people complaining about slow notifications after Oreo and Pie updates and that Doze was the problem and stated that if you disable Doze, your notifications will work correctly again (near instant). I tried this and can confirm that all my notifications (including SmartThings) are working correctly now.

Now for the PITA; the only way to disable Doze is by using ADB.

  1. adb devices
  2. adb shell dumpsys deviceidle disable

"adb devices" will show your android device that is connected via USB with ADB debugging enabled.
"adb shell dumpsys deviceidle disable" will disable Doze.

Please note that the above will only disable Doze until you reboot your phone. If you want to have it disabled all the time, then you need to root your phone and set a script that runs the “adb shell dumpsys deviceidle disable” command on startup. I personally do not reboot my phone often, so I will just run the command when required. I am also hoping that google will fix the notification delays caused by Doze with updates.