Android notifications marshmallow


#1

Hi. Is anyone using Android marshmallow and not recieivng notifications at the time they happen? I’m based in the UK so not sure if this is specific to UK or not!

Since upgrading my Nexus 5 (and my wife’s new Nexus 5X shipped with marshmallow) to marshmallow I do not receive notifications if my phone is sleeping (new to marshmallow is the battery saving tech Doze that puts phone to sleep if it sits idle on a desk etc). This means that if my phone has been sleeping I receive my SmartThings notifications (all incorrectly time stamped when I picked up phone - but correct in SmartThings) only when I pick up my phone.

This isn’t helpful since I want to know when my SmartThings semi-automatic mouse trap locates a mouse! :slightly_smiling:

Any advice please? Thanks.


#2

I haven’t found a fix yet. I can’t get an alarm to work on marshmallow at all, so it isn’t just smartthings. You should be able to receive text messages even while sleeping, so if you have it send you a text instead of a notification, that might work. I don’t think there is a way to turn off Doze. I have battery optimization turned off, and my phone still goes to sleep at night. On my Nexus 5, if I kept it charging at night it wouldn’t go to sleep, but my new phone still goes to sleep even though it’s charging.


(John Crighton) #3

There is a way to exclude specific applications from Doze. I’m running M and have been for a while. My alarm goes off every day, no problem. I also get ST notifications as I have excluded ST from Doze.

I’d love to be able to tell you how, but the screen on my Nexus has given up the ghost. I have a 6P on order though, need it asap - life is hard without a device!

Edit: a quick Google produced this: http://www.addictivetips.com/android/how-to-exclude-apps-from-the-doze-feature-in-android-6-0/


#4

Thanks Guys. John I’ve tried this already and it doesn’t work for me. It seems developers must code for Doze possibly to allow exclusion - I’ll do some more reading to check.

I’ve just found a setting in Settings->Apps->SmartThings->Notifications and changed “Treat as priority” to True. Sometimes I set my phone to “Do not disturb” during night and this might overcome that hurdle. I appreciate this is a different scenaro, i.e. the problem I’m having is when “Do not disturb” is not set.


#5

I have “Don’t Optimize” and my phone still goes to sleep at night even while plugged in. I have a Axon Pro, and I think one issue with my phone is that once it is 100% charged it changes its state to Not Charging. Any app that looks for a charging state will not run even though it is still plugged in.


#6

Ok. John is suggesting that you select “Don’t optimize” for the SmartThings App. So if your phone goes into the Doze state the SmartThings app will ignore Doze and still send notifications etc. I have tested this and it doesn’t seem to work for me so I am re-testing! I’ll report back…


#7

I agree, I already had “Don’t optimize” selected, and it still didn’t work. I’ve set the notifications to priority and I’ve set llama to turn on the wifi every 5 minutes all night to try and keep the phone awake. I’ll see if it makes any difference.


(John Crighton) #8

Having said what I’ve said, I don’t get that many notifications from ST. It’s entirely possible that they’re queuing up, and I get them when I ‘undoze’, but I didn’t think that was the case.

Unfortunately due to the current state of my device, I cannot test :frowning:


#9

Thanks for the updates. I think the SmartThings developers need to code for the “Don’t optimize” to work correctly but I’ll let you know what my findings are. I would have thought that this would be a major issue for many people but after Googling I can’t seem to find anything on it (hence my posting).

Anyone else experiencing this issue?

PS Enjoy the 6P John - mine is soon to follow :slightly_smiling: (I now wait a few months after a new product release - I always seem to get problems that are fixed later!)


(Darren Flanagan) #10

running marshmallow on my s7 and its working fine. Notifications coming through perfect each and every time :smiley:


#11

Thanks Darren. Could you elaborate a little more please? Have you added SmartThings to the Don’t optimize list? I get all notifications perfect each and every time too, the problem however occurs when phone is in Doze state (left on desk for a period of time, when I go to sleep etc). The notifications only reach the phone when it is picked up i.e. comes out of Doze state. Have you checked this?

Also what phone do you have? S7 is due to be released 11th March I think :slightly_smiling:


#12

Here is an interesting link

I suspect notifications are sent as ‘normal’ priority. Maybe we need an option to send as ‘high’ priority (phone will exit Doze mode) so that notifications are instant?


(Darren Flanagan) #13

I took it off the optimisation list. I also added an exception to dnd. My house goes into alarmed home state at 11:00 and my phone is on the wireless charger from about it 10. If I open the door to pop outside the notification comes through straight away.

Also using an S7 Edge :smiley:


#14

Thanks Darren. Nice phone :slight_smile:

Samsung has changed interface slightly but I don’t think manufactureres are allow to fiddle with the Doze code so it should be consistent. As siuenger mentioned above if phone is charging Doze doesn’t enable so that could be why you are receiving notifications immediately - I’m having hassles when phone is not charging!