Presence on mobile broke with Android Marshmallow?


(Patrick Roark) #1

It appears that when my phone goes into deep sleep mode my presence gets changed to away. There for my hello actions become triggered.

I know it has something to do with sleep becuase when I pickup my phone and unlock it immediately triggers I’m home hello action.

Pretty weird but I assume it’s related to new battery saving featured in Android M. I have a Nexus 6.

Just posting for feedback and to get a feel if anyone else is seeing this.


Can I run app but not act as presence device?
#2

Agreed, I believe it has to do with Marshmallow’s new Doze setting. SmartThings needs to update the app to better handle this.

I’ve had to turn off the presence system as it’s basically useless now, constantly triggering when I leave my phone alone for an hour or two.

As an aside: why doesn’t the app offer the ability to use WiFi networks as “present”? If I’m connected to my home WiFi, it should be pretty obvious I’m home.


#3

Funnily enough, I’m on a nexus 5 with marshmallow. My presence appears to come and go all night long, whole my wife’s galaxy s4 on Android 4.2 stays pretty stable.


(Kristopher Kubicki) #4

@Fourier - Please appeal to the ST team on this! I have been saying for a while that local presence could be better handled if things like Bluetooth, ICMP Ping and Wifi were utilized. The Hub can do all three!!

Kristopher


#5

You can set certain apps to not be affected by the new Doze feature.


(Patrick Roark) #6

I’m interested in this. Would be a good test to see if Doze was really the issue. I’ll look for it through the settings.

I agree with others about different metrics being used for presence.

Edit: I checked everything and nowhere did I find anything that allowed me to turn it off just for smart things app. Even looked in developed options.


(Nowhere Man) #7

I’m having this issue with my Nexus 5. I found these instructions for disabling battery optimizations for individual apps. Not sure yet if it will work, I just flipped the switch on the ST app a few minutes ago. Fingers crossed.

EDIT: It did not work. 30m later ST marked the device as away when it isn’t :confused:


#8

Disabling the battery optimization for the ST app does not do anything, unfortunately, as @nowhereman discovered.


Android Presence not working since last week (reported Apr - June 2016)
(Tony Gutierrez) #9

This just started happening to me, and I dont have marshmellow yet. If my phone is idle it sets away.


(Josh Costanza) #10

My Nexus 5 also updated to Marshmallow and now have the same problem when the device sleeps and puts me into away mode where it has been working pretty descent for over a year. Even though Im on the home wifi it still shows me away and Im triggering false alarms for every door and motion sensor I use. My wife has a Nexus 4 on latest Lollipop with no issues and her geo fence and presence sensor works perfectly fine. Only major difference between our devices other than OS is LTE on the Nexus 5.

I’ve gone into the Battery Optimization and set a few services to Not Optimize to see if this helps. I’ll try to update as I see what works. I’ve attached a screenshot of the services that might be preventing the location from being determined while the device is Dozing. If it works, I’ll start eliminating one by one to see if I can track which service might be doing it.


(Josh Costanza) #11

We’ll my tests showed no difference in results when setting Not Optimize for the new Doze feature on Marshmallow.

When I first set all the apps to Not Optimize, SmartThings showed my device as home. I let the device go to sleep for about 30 minutes which is past the Geofence delay of 20 minutes that I have set. When I checked SmartThings Dashboard, it showed I was Away which is the behavior I have been getting with the Marshmallow updates. I checked the dashboard every 15-20 minutes to see if it would update but it did not.

The only way I can get it to recognize that I am home is to open Google Maps to get my fine location and switch back to SmartThings where it quickly updates.


(Emily Shuey) #12

Jumping to say I have the same problems on my new Nexus 5X. Last night, all the lights turned on at 12PM and 3:15AM, because my phone thought I went away and came back. It woke me up both times!


#13

So far, life360 seems to be much more reliable at detecting home/away for my nexus 5. Just a reminder / suggestion for those looking at alternatives.


(Jon Paterson) #14

does the new 2.0.4 build fix this problem? I see nothing in the notes related to this.


(Kristopher Kubicki) #15

Yep, just upgraded to Marshmallow last night and same issue.

I am on WiFi. I feel ST could put more time into this. None of my doors opened… So how could my presence go away?

Supposedly Doze does not activate if the phone is plugged in. This behavior happens when it is, which leads me to believe it might be an optimization outside of Doze?


(Darren) #16

…also jumping in to say “yep, happening to me!” - Nexus 6P, if my phone is home and not plugged in AND goes into Doze, my “Goodbye!” routine runs.

Looks like some permissions need to be added to the app - https://developer.android.com/reference/android/Manifest.permission.html#REQUEST_IGNORE_BATTERY_OPTIMIZATIONS
https://developer.android.com/reference/android/provider/Settings.html#ACTION_REQUEST_IGNORE_BATTERY_OPTIMIZATIONS


(Kristopher Kubicki) #17

Not sure if this was fixed on ST side or if I did it somehow on my side. However, I don’t seem affected by this anymore.

Kristopher


(João Cautela) #18

Hi,

I don’t know if some one can help me with this, already try the customer support, still waiting for a answer.

My Mobile Presence log show this >

Fri 07:46:43 REST call : FAILURE : Elohim Palace 403 Forbidden
Fri 07:46:43 REST call : FAILURE : Elohim Palace 403 Forbidden
Fri 07:47:19 Event fix: 38.7450, -9.1947, acc= 61.5m
Fri 07:47:19 E: 819m E: 819m E: 819m E: 819m E: 819m
Fri 07:47:19 ** Exit Event for : Elohim Place :
Fri 07:47:19 ** Exit Event for : Elohim Place :
Fri 07:48:23 REST call : FAILURE : Elohim Place 403 Forbidden
Fri 07:48:23 REST call : FAILURE : Elohim Place 403 Forbidden

I have change already (for a 3 time) the name of the location of the hub, but in the log there is still that 2 “old places” (Elohim Place/Palace) .

Another thing, i have set a timer “only during a certain time” (when i use the first name) already uninstall, but that didnt work, because the only works with in that timer (the action is to turn on the lights).

Funny thing is that in the log, doesn’t show the name that im using now.

Thank you.


(Carson Dallum) #19

Both my wife and I have Nexus 5 phones and have also noticed presence flakiness recently. What’s weird is that it doesn’t appear to be confined to ST. Earlier this week my wife’s ST presence, Life360 location and Android Smart Lock weren’t working. When I checked her location in Life360 it showed her at home during the middle of the day even though she was at work all day. That night I restarted her phone, and location has been good again for the last few days. Not sure why but it appears a restart is the best (temporary) option for us right now.


(Paulo) #20

I can confirm that doze mode is disconnecting the presence capabilities of SmartThings. Nexus 6P and Nexus 5 running Marshmallow both look as if they have left the house after leaving them on the table for an extended period of time. As soon as I pick them up and turn them, on my lights turn on as if I just arrived at home. I’m more concerned with the fact that everything will turn off as soon as SmartThings thinks we have left the house. This will really mess with routines and lighting. Luckily, I use my phone a lot. However, I foresee a situation when all of the lights go out my kids start screaming an my wife puts an end to SmartThings. This needs a solution or at least a workaround YESTERDAY!!! Any suggestions?