Android apps can't delete mode


(Ray) #1

Not sure if this is a known bug but I wasted quite a bit of time trying to delete a couple of modes I created a while back. The modes came back after a successful removal. I ended up going over all my smartapps and unchecked the modes I wanted to delete and that was the problem. Why is there no warning like removing a device with a smartapp still attached to it? I did a search on the forum with no success.


(Mike Maxwell) #2

Yup, having the same issue. A duplicate just popped up in the last day or two, was able to rename it, but not delete it.


#3

9 months since last post. Guess they don’t care about fixing this. I can’t delete modes.


(Ray) #4

You can delete the mode. Just have to remove that mode from all the smartapps first.


#5

At first I thought that was the problem.


(Ray) #6

Unfortunately the other option is ST support. I did have one mode that I could not delete due to corrupted data according to ST support.


#7

There’s a command to delete modes in IDE. Maybe that would work. Once signed in, click on “My Locations” and then click on the mode.


#8

Thanks I tried that too. I’ll put in a ticket I’m sure it’s something I’ve done. Pretty new to this and going through a lot of trial and error. The extra modes aren’t causing problem. I just want to cut down the clutter and confusion.


(Rob) #9

2 years later… “Access to graph-na04-useast2.api.smartthings.com was denied” after trying to delete in the IDE.

Edit: I thought I had deleted all references to the mode. I went back in to my RoomsManager smart app and saved everything again just to be sure. When I then tried to delete, it worked. Not sure what happened.


(Daniel Ionescu) #10

Time is standing still.
2018-02-11_20-38-27