Android app crashes with Motion sensor

Just got my new kit and was very excited, but the first device setup itself is failing. I added a motion sensor and during configuration app crashed. Now it is showing as an un-configured device but whenever I do anything with setup involving motion sensor, app crashes. I tried on my wife’s Android phone as well, same result.

I am not able to find any workaround, please help.

*Update - Cleaned cached, re-installed app, Also deleted the sensor, reset and added again, but app is still crashing.

I tried to make a change in the app this morning and it crashed every time I tried. I just gave up.

This is something new… if you haven’t already, please submit tickets to support@.

This is happening to me also, incredibly frustrating as working with no issues yesterday, and to double check it wasn’t a rouge smart app i deleted all my smart apps, so now have a defunct system as i cant add any smart apps anymore as they all rely on the motion sensors. clearly this is just a bug with the app and how it handles motion sensors…please fix asap, im getting a little tired of smart-things qirk for throwing tantrums randomly

This is happening for me as well. I have a device “not yet configured” and every time I try to add it the app crashes. Very frustrating

“Solution” so far is install the iPhone app on my iPad (as there is no tablet version) and I can complete setting up the device. Would be great if the android app was just fixed.

Same issue here on the Android app setting up my SmartThings from fresh after moving house. Motion sensor worked fine at my old house. Have opened a support request.

@peat - I think I found your ticket… you are in the UK?

@casaccio and @tyrch are yall in the US or UK? (I am trying to narrow down if this is shard specific). Please DM me ticket numbers if you contacted support

Yes, I am, will DM you the request number to make sure you have the right one.

Can’t figure out how to DM you (maybe I can’t because I’m new?). It’s ticket number 271380.

I wish it was because I had some magical powers. I checked with the team and it turns out there is a wonky Android issue where the app crashes when a motion sensor pairs with incomplete battery data. Our engineering team is working on a fix now. Couple short term workarounds:

  1. Remove & re-add the battery, and try again
  2. Use a non-iOS device

Hey, Aaron, am in the UK, didn’t contact support as I worked around the problem using an iOS device.

If I go out and buy an ios device, can I send you the bill? :wink:

Just removing and reinserting the battery didn’t fix the crash.

I got a reply on my support ticket which suggested deleting the device using the IDE and then adding it.

First attempt I just deleted the device and then searched for it again. The hub found the device once more but when trying to set it up it still crashed.

Second attempt I deleted the device again, then reset it (pulled battery, started the hub searching for devices, held down connect button on the sensor and reinserted battery). I was then able to set it up without the app crashing.

Awesome - thanks for the patience. I flagged this for investigation

Had this problem til now, found a workaround.

The issue is device not setup, motion sensor then white page on the Android app and crash.

Do this instead:

  1. Remove battery from motion sensor
  2. Tap ‘Device not setup’
  3. Tap ‘Motion sensor’
  4. Reinsert battery now
  5. finish setup. Works fine.

Just received 2 of theses sensors and had the same issue. I found out how to connect it (worked for me).
Instead of selecting “start looking for things”, I selected “smartthings recommends - motion sensors - samsung …” then “connect”.