Help Needed - App crashing after deleting smartapps


(Mike Martin) #1

I sent the following to support as well, but figured I’d see if the community has any good solutions too…

Hi there,
This morning, I thought I would start a clean slate with smart things (I’ve added quite a few devices recently and wanted to be better organized). So I went in and deleted all my smartapps, hoping to start anew. However, I think I broke something because now the following errors happen frequently (and almost always reproducible).

  1. I can’t add an alert for a presence sensor - Just get a big red bar at the top saying ‘unknown error has occurred’.
  2. When attempting to add an action for lighting, the app crashes. (when I click next after choosing ‘turn on when people arrive’.

Various other things in the app seem buggy as well.

So, as I said, I’m sure something went whack when I deleted all the smartapps, but I’d like to get it back to original. Can you help?

Thanks!
Mike


(Morgan) #2

I would go into the IDE, and check the different devices and remove them and apps in there and start over it sounds like to me.

Or did you try rebooting your hub 1st?


(Mike Martin) #3

@thrash99er Thanks for the reply!
All apps have been removed, that’s what caused these issues in the first place. Per supports recommendation, I have restarted hub and force quitted the app. Still same issue.

Steps to reproduce:

  1. Tap + sign
  2. Go to alerts
  3. Tap ‘Family coming & going’
  4. Tap ‘Notify me when a family member arrives and/or departs home.’

Now a big red box appears at the top saying ‘Error: An unexpected error occurred’


(Eric) #4

If you haven’t checked inside the IDE (“integrated development environment”?) already then go there, and try to delete any installed smartapps from there instead of the phone app.

https://graph.api.smartthings.com/login/auth

Chances are you still have some links


(Mike Martin) #5

@ero4444
Thanks, yes did all that. Still was having issues… Something support did fixed it though. My gut says there was some bug that creeped up, as everything was crashing.


(Tim Slagle) #6

Probably not. It was probably a database issue on your account. They below out your database and all is well again.


(Brian Crocker) #7

Getting the exact same issue as this, added a SmartSense Presence and when I went to setup the notify me I’m getting the red box. Have done all the suggestions in this thread already and no luck. I’ve opened a case with support and waiting to see what happens. Anyone have any other suggestions?


(Tim Slagle) #8

With issues like this support is really the best avenue for support. They are great :smile:


(Brian Crocker) #9

Yeah, they said they had more than one report of this last night. They fixed it on their end and It’s working now.