SmartThings Community

Android App - All Devices gone


(Ed West) #1

No too sure what the heck is going on but I went into my Android app today and all my devices are gone?

Logged out and back in and still no devices? I can log into the hub and see them listed in my devies? How do you get things back into the Android application?

I have another smart hub from a different company and I have never had any issues like this losing my devices. Any help would be appreciated.

thanks…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

If you can see them at https://account.smartthings.com then be sure to pick the right Location from the top left in the App.

Also… You may have a conflict between Samsung login vs SmartThings login.

Don’t hesitate to email Support@SmartThings.com


(Ed West) #3

@tgauchat Thanks for the response.

I have tried everything to get the android app to talk to my HUB. I have a Samsung phone and it always try my logged in account. So, I ended up removing the account from my phone, reinstalling the app and I only see my TV at my house. I do have my Samsung tablet that still is showing all my devices? So I guess what is weird is that I see my Samsung TV at my house but nothing else?

I am sure that there is something with logons but I can’t get it to show. Maybe the problem is because I own so many Samsung things TV’s to tablets.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

Keep in mind that for SmartThings the Android App does not talk directly to your Hub.

Everything goes through the SmartThings Cloud which you can also access at: https://account.SmartThings.com

If that web URL login does not work, then the SmartThings App won’t work either. If it works (and lists your Location / Hub / Devices), then the SmartThings App should work too.

Contact Support@SmartThings.com for assistance.


(Ed West) #5

Thank you for trying to help.

I can log into https://account.SmartThings.com and everything is there. I think you are correct that there is a account mismatch going on. I have a developer login to Samsung as well so maybe that login is getting confused as my regular account. I am talking with support at the moment. Just weird.


(Chris ) #6

I had problem with things disappearing from app over weekend, all it took to correct was sign out of app clear cache and sign back in.


(Ed West) #7

Great idea and very helpful but no dice.

Thank you for the suggestion.


(Chris ) #8

Yeah now a no go for me too, devices gone again… well not all like you’re experiencing but hue blooms and 2 others.

Good luck!


(Pugazhendhi M) #9

Guys ,

Please check you have multiple locations and empty locations.

If so, try delete them or select the one location which contains the devices, This will bring back your things.

Try selecting the menu (3 lines) and select your home location which contains the devices, which will bring back the devices, if not you are not able to delete the empty locations.

Thanks and regards,
Pugazh