Smartthings App Devices Gone

I seem to have lost all my devices in the Smartthings app. I can see my hub and rooms but no devices. Hopefully, I can recover the devices because I dread having to re-pair all my devices. Any idea of what could have caused this.and what can be done about it? Thanks for any and all comments / suggestions.

do they appear in or

if they do not appear in both my.smartthings and the app, you should contact ST support.

if they do appear in my.smartthings, sign out of the app and sign back in. Also check that you are in the correct location.

Do not reset your hub nor reset any devices as it may not resolve the issue.

1 Like

You can take the advice @jkp has offered to see if the devices can be seen outside the app.

You might also like to click on the the three dot options menu on the Devices page in the app where there is a ‘Select devices to use’ option. All the devices you have access to should be listed there but only the selected ones are visible in the app.

If you have been ‘invited’ to your Location rather than being the owner you can also hit the icon next to the Location name on the Favourites page to check you have access to all of the devices.

1 Like

Thank you so much @jkp and Graham Developer. I tried all the suggestions and still no luck. I contacted ST Support by email about 2 weeks ago but no solution yet, other than asking me to give them access to my account, which I did, In the meantime, I’m still trying whatever I can since not having Smartthings is very inconvenient for me (I am a 76-year-old senior and need to go downstairs in the basement to manually turn/off my kitchen and other lights on the main floor).

I just noticed yesterday that my Samsung version 2 hub is continuously flashing blue. I wonder if that’s related to my problem, and if so, how I can I correct it.

Any additional comments/suggestions would be greatly appreciated.

did your devices show at If they do not show there… there isn’t any advice the community can provide as that would be an issue only ST support can resolve.

but… Blinking Blue: There is no Ethernet or WiFi connection.

You may want to try switching out the Ethernet cable for your V2 hub or connecting it to a different port on your router or network switch to see if the hub returns to the normal green led light on the front of the hub. Reboot your network router also.

another option is a soft factory reset by following these directions:

  • Disconnect the power cable from the Hub
  • Using a pin or a small tool, hold down the reset button on the back of the Hub
  • While continuing to hold down the reset button, replace the power cable
  • When the LED on the front starts flashing yellow, release the button

soft reset only wipes out the network settings of the hub. Soft reset does not affect devices or routines.

Please Note: release the reset button once you see flashing yellow. If you continue holding until it becomes a solid yellow then everything is wiped out - a full reset and you do not want that.

1 Like