Everything is gone from Samsung Account upgrade


(Jack) #1

Hi,
So I just upgraded my SmartThings account to Samsung (because an update showed up on the SmartThings app for a “migration”). But I noticed that all my Hub, Devices, DTH, and SmartApps were gone in the IDE. Is there a way I can retrieve them back?

Edit:
According to https://support.smartthings.com/hc/en-us/articles/115001554526-Samsung-Account-Update-FAQ, “While Samsung will manage your login credentials, nothing else with your SmartThings Classic app Location settings and devices will change.”

This is apparently not the case for me.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Your Things are probably just under a different Location than the default being shown in the App.

And/or give it a few hours to synchronize the Account!

Then…

Login to https://account.SmartThings.com and carefully examine the My Locations tab. One of them should contain your Hub and Things and you can edit it and make it “default”. The other(s) can be deleted if they have no Hub & Things.


(Jack) #3

It’s been 4 hrs. So I checked again - my location is “Home” (only location that shows up), but still no ST devices. The only device I see is my phone.

Note: I had made a Samsung Account a long time ago under the same email as SmartThings. Could this have any cause to the problem?


(www.rboyapps.com - Make your home your butler!) #4

After logging in click on my locations and then click on your location. Then try to go to my device handlers. For some reason when you login it takes you to a default location which is not in your locations list for some users.


(Jack) #5

I only have 1 location show up though. And there’s nothing in it.

image


(www.rboyapps.com - Make your home your butler!) #6

Click on it and see if your hub is there. If not you may need to contact ST support.
Even thought you may have one location when some folks login it sometimes default to some unknown location which is why it’s safe and important to click on your location after logging in.


(jkp) #7

Are your devices showing in the ST app?


(Jack) #8

Yes, my devices still work in the ST app.


(jkp) #9

I wonder if perhaps you are logging into IDE with the wrong account. Are you being prompted to choose between a samsung or smartthings account when logging in to IDE?


(Jack) #10

I used to get that option, but now it automatically makes me sign into Samsung only.


(jkp) #11

There was another user having a similar problem where they were not seeing their stuff in IDE. What they did was change their samsung password in the ST classic app and then they logged into IDE and everything was fine after that. it may or may not resolve your issue.


(Jack) #13

Strange… I tried signing into my other Samsung account (used for testing Samsung Connect app a long time ago). And sure enough, I found all my hub, devices, etc. there. It seems that all my stuff had moved to that account now.

I looked at my SmartThings app, and I could see that there were 2 owners (not 1 owner and 1 shared). Yet only 1 of those accounts has access to all my stuff. How is this even possible?


(jkp) #14

the 2 owners is a known issue after the account migration.