Android 2.2.2 - Release Notes

I don’t get it either. This is one of the best home automation platforms around and that’s INSPITE of the company itself. If it were not for the community it would NOT be worth it and I just don’t get how the unpaid community can do so much right, and carry the platform on its shoulders but those being paid and making money can get so much of it so wrong.

This is unacceptable.


Daaaamn straight!

I hereby raise the amount that SmartThings pays the unpaid ST community by 150%.


I saw the same on Wednesday night with Android 2.2.1 before any updates rolled out.


Sure, this is an Acer B1 770.
I went for Acer as I believed, and still believe, they are a reputable company.

I believe that the security issues are more at the Android OS and Android Apps level rather than the hardware itself! Google barely control or clean their Play Store. Anything can be found on the play store (boosting the number of apps), including dodgy apps which look genuine… If you look at the play store, there are tonnes of apps which are identical in their functions (“you tube” and other media players for instance) but under different names, etc… Simply look at what the app can access, most of it is not required for the sole purpose of the app. Hence this is a way to collect data and even perhaps install malicious code as part of the app install process…

Therefore, my data breach could be from any app on the Android tablet!. I tried to monitor my network and use the tablet a the same time to see what actions/app on tablet trigger the security alert on my router.
Again a few days ago, my router block IP packets from the tablet. It was sending details about the tablet, my location, my local wifi networks, storage, the app installed on my device, etc, etc. to “” in China.
Previously, with the same device, my router blocked IP packets containing trojan code and targeted to the Android tablet… once again, the source IP was located in China and Russia…
Another time, a TOR server (“Dark web” entry/exit point) also tried to connect with my Android device, once again blocked by the IP Deep Packet Inspection on the router.

Anyway, I have no such issues of targeted attack on any of my Windows devices, be it my desktop, laptop or mobile.

So, although there was an article online, a few weeks ago, claiming that some budget Android tablets shipped with a “built-in” backdoor to China, etc., The guilty one is most likely Android OS and the Play Store.

Good luck :wink:


Thanks for reporting these issues so far. Our Android team is investigating.


Hopefully they will provide a fix very soon

There is an older version back on the CoRe site. You need to uninstall this version and reinstall the old version and select do not update in the settings. Everything is working fine again

Thanks for these steps Bobby.

We are able to reproduce internally and are actively investigating. Right now we don’t think it is related to the mobile release but instead related to a cloud release that occurred yesterday. If you are experiencing this, please contact support or PM me your ST username so we can gather that info.


the problems are the mobile release. I have no issue on the 2.2.1 mobile release

1 Like

After reverting to 2.2.1, I am working again. Then this afternoon, I noticed a change that really scared me at first. I went into Routines and didn’t see the tab for smart apps. I was afraid I lost them all!.Then I hit the hamburger menu button and saw them on there, below the notifications. So they have been moved somehow.

same situation here 2.2.1 is working fine. Maybe the cloud update and 2.2.2 in collaboration? No idea… Unfortunately not funny…

Sorry for my question, but could you please provide the link? That would be very helpful. I looked around but unfortunately didn’t find it…


Edit: Believe I found it!

1 Like

Do a search for smartthings. Save the .apk file to your Google Drive.
Delete the SmartThings app.
You will have to go into Settings/Security and check Unknown Sources
Then open the file from Drive on your phone.
Don’t forget to uncheck Unknown Sources after it installs.


Glad you found it.

Thanks a lot for your thorough answer. Again, do you mind telling the model of your router? :slight_smile: I like that IP packet blocking function it has.


Sure, my router is a Synology RT1900ac

The IDS (Intrusion Detection System) analyses the network traffic (IP packet) against a database of know threats…

You can create rules to:

  • do nothing: Let the packet through
  • drop: Delete the dodgy packet, hence blocked
  • alert: Let the packet through but alert you (email etc).

You can also blacklist / whitelist IP addresses…
Etc, etc, etc…

Hello, we were able to address the CoRE issue in 2 ways. First, we have sent the developer a work around for their SmartApp. Second, we have just submitted a hot fix for Android to address the same issue. Android 2.2.3 fixes the issue users are seeing with the CoRE SmartApp. Thank you for your patience!


Thank you @kleneau, CoRE has been updated to include - applause please - a fix by SmartThings! SmartThings offering deep support to a community app. Hats down to @all at ST. Put a tear in my eyes :wink: thank you


LOL, I can confirm your fix and 2.2.3 both worked. I can now update my Pistons. Thanks @ady624 and SmartThings for the quick response to the community.


Impressive turn around. You guys are awesome!