Smartthings and Alexa Issue

Hello Everyone!

I’m new to Smartthings so I hope I’m not asking some obvious newbie questions. I did search for answers here but couldn’t find the ones that would help me.

I recently set up my Smartthings hub with bunch of lights, switches and other stuff. Then I enabled the Smartthings skill in Alexa and everything was working perfect for few days.

But suddenly, my 3 Wemo bulbs no longer respond to Alexa voice commands and show up as “device unresponsive” in Alexa app. These bulbs are working fine in the Smartthings app with the Alexa smart app enabled.

Here’s what I’ve done so far to troubleshoot this issue:

  1. Disabled Smartthings skill in Alexa and re-enable it.
  2. Removed the Wemo bulbs from Smartthings and re-added.
  3. Reset the Wemo bulbs and rediscover them with Smartthings app.
  4. Changed the name of the Wemo bulb in Smartthigns app and rediscover it in the Alexa app (the bulbs with new names are discovered OK by Alexa but they still show up as “device unresponsive”).
  5. Logged out of Smartthings app and logged back in.
  6. Remove my Home location from the Smartthings app. Then set up the hub again with the Welcome code. This forces me to rediscover all my devices.

I’ve done a combination of all of the above and yet the Wemo bulbs are still showing up as “device unresponsive” and does not respond to Alexa voice commands.

They worked fine for few days so I know they can work but for some reason stopped working.

Anyone have any idea why this happened and how I can get these working again?

BTW, I contacted Smartthings support and all they provided me with is how to add Wemo bulbs to Smartthings. Since I’ve already done that and I have no issue adding these bulbs to the hub, support wasn’t much of a help.

I have the exact same problem with a peanut plug. Has worked for many months.

It’s quite odd as in logging the Alexa app is seeing the device offline but it’s fine online and working in the smartthings app.

Waiting to hear from smartthings support but nothing I have tried will fix this.

1 Like

This is very frustrating. I’m afraid Smartthings will say it’s an Alexa issue while Alexa will say it’s a Smartthings problem. :frowning:

What’s more strange is that this is only happening with the 3 Wemo bulbs. Other devices, including Wemo light switches are working fine.

I haven’t tested all of mine but so far only one is broke of many devices. i am sure there is another I haven’t found yet

All these experts and no one knows why Wemo bulbs work fine in Smartthings but not in Alexa?!

I’m wondering if it’s a conflict with Alexa trying to discover the WeMo devices separately from SmartThings… WeMo’s, I think, are discoverable on their own. Have you tried taking the WeMo’s out of the Alexa SmartApp device list? You wouldn’t technically be controlling them through SmartThings, but they would still report to both systems at that point, in theory, so it shouldn’t affect reporting. (I don’t have a device to test with. This is just a guess from some reading I’ve done…)

I know it seems very counter-intuitive, but it may be seeing the same device being discovered from two separate sources (the device and SmartThings) that is confusing it. Something to try, at least.

Thanks for the advice. I’ll try and report back.

Unfortunately removing the Wemo bulbs out of the Alexa smart app didn’t work. I also have Wemo switches and they show up twice in Alexa app, one as Belkin the other as smartthings.

It’s so frustrating because they worked fine initially…

DI am quite sure this is a backend issue that no playing by us will fix besides maybe removing and re-adding which is a giant pain.

*edit I see you removed. Hmmmm

I spoke to support about this issue yesterday.

In my case, it is something to do with switching over from a custom DTH to a local DTH (in order to take advantage of local processing). Once I switched back to the custom DTH, all my devices are working with Alexa again.

They are aware of the issues and working on them.

Seems switching my DTH to a different one and switching back fixed it or just lucky coincidence.


1 Like

My Iris SmartPlug 3210L suddenly started acting up with the “not responding” Alexa response. I tried changing to the “SmartPower Outlet v1” in the IDE and it’s magically working again…

1 Like

My Wemo bulbs are working with Alexa again…kind of mysteriously. All I did was remove the bulbs from Alexa smart app within the Smartthings app and then re-added them back in. It didn’t work right away but after a few hours I noticed it was working.

Bottom line, I’m glad they are working!

Thanks everyone for help and advice.

mine is doing that . Should I leave it there…listed twice in Alexa…as Smartthings and as wemo/belkin… I am growing weary of this troubleshooting because I have tried many different angles to try to get them to communicate