Alexa displays device as unresponsive while ST shows the device is active

I have been using ST and Alexa now for a couple months. I originally had the ST plug that came with ST HUB V2. “square plug”. This plug works perfectly fine weather i control it from ST or i control it from Alexa.
Due to the black Friday deals as well as aesthetically pleasing design, i have purchased 4 additional plugs, however i purchased the “new” Samsung ST Plugs (Samsung SmartThings F-OUT-US-2 Outlet)
I was able to connect ALL 4 devices to ST without any issues, i can turn on/off from the app as well as add them to routines or scene without issue as well. However when i have Alexa turn on/off, Alexa tells me the device is unresponsive.

I have rebooted the hub
Forgot all devices on Alexa and re discovered
Deleted the device from ST and re-added
I have searched these forums and other forums and cannot find an answer to why this isnt working.

da1a0450-6b52-434c-8cda-3c55eb83578c 11:08:47 PM: debug handlePostV3
da1a0450-6b52-434c-8cda-3c55eb83578c 11:08:39 PM: error Outlet is offline
da1a0450-6b52-434c-8cda-3c55eb83578c 11:08:39 PM: debug handlePostV3
da1a0450-6b52-434c-8cda-3c55eb83578c 11:08:33 PM: error Outlet is offline
da1a0450-6b52-434c-8cda-3c55eb83578c 11:08:33 PM: debug handlePostV3

1 Like

I’m having this same exact problem. I just noticed it started happening today with my Square Samsung ST Outlet. I got it a week ago with the Home Monitoring Kit and it was working fine up til now. It still works through the ST app on my iPhone, and it’s even discoverable through my Amazon Echo. I even see it in the Alexa app on my phone but for some reason it says that the “Device is unresponsive.”

I’ve taken all the steps you’ve taken as well, but nothing’s worked.

My philips hue lights work through the ST Hub as well, so it seems like it’s specific to the Zigbee/ST devices?

I’m wondering if the recent Firmware update had anything to do with it. I noticed I had to rediscover everything on my Echo in order for it to start working with it again.

Hi JD,

This isnt the issue that i am facing.

ST Shows plug as online
ST can turn on/off the plug
When telling alexa to turn on/off she says the device is unresponsive. (ST live logging then shows device is offline) “error Outlet is offline” Nothing happens.

1 Like

I seemed to have fixed my issue by resetting the hub through the developer’s portal:

If you click on your home location and then on the hub you’re able to view available utilities. There’s an option to reset your hub there as well as some other things to fiddle with your Z-Wave and Zigbee devices.

Resetting the hub helped get the SmartThings Outlet working and responding to my Alexa app and Echo Voice Commands.

1 Like

So, I also hit the issue where a device shows online in ST but Alexa thinks it’s offline. In my case, it is something to do with switching over from the OSRAM RGBW custom DTH to the local Zigbee RGBW DTH (in order to take advantage of local processing). Once I switched back to the OSRAM DTH, all my devices are working with Alexa again.

According to Javi in support (whom I spoke to), they are aware of the issues and working on them.

Having the same issues here too.

The square plugs I have are originally Iris plugs. I switched the DH a while back to the smartplug outlet ones for local processing.

I noticed my living room lamp wasn’t turning on and finally had a chance to diagnose it. Getting the “debug handlePostV3” from Alexa in the logs. If I switch back to the custom DH i originally used, it works again. Switch it back to the smart plug outlet DH and doesn’t work.

My bedroom lamp now isn’t working but was though. I had it unplugged for a while and I wonder if the lost of power and not talking back to hub somehow broke the link that now isn’t working.

1 Like

I’m having the same issue with my Phillips Hue lights. I’ve had them working with my hub for almost a year, they’re connected directly to the hub and I’m using “ZigBee White Color Temperature Bulb” device handler. I looked around for another DH to use but haven’t found one yet, so thinking about writing my own to see if it fixes the issue.

I had the exact same issue that started recently. Philips Hue White Ambiance bulbs connected directly to ST hub. After recent Alexa updates, bulbs were reported by Alexa as ‘unresponsive’.

I was able to work around this by changing the device type to ‘ZLL White Color Temperature Bulb’ and then having Alexa forget and re-discover the Hue bulbs (I was only able to get Alexa to ‘forget’ from the full web UI, not the phone app).

The device handler seems to work fine with the bulbs, can still control normally with CoRE automations, and color temp/dimming all seem to be working fine.

Hope this helps.

1 Like

That works perfectly, didn’t realize ZLL was a device handler I could use. I didn’t even have to do anything in Alexa to get it to work. Everything seems good to me here!

so how do iI fix my plug that is now unresponsive. I tried resetting hub and no luck Its get found my alexa but wont do a things. smarth things it works perfect.

Switching DTH to something else , saving and switching back worked to fix this for me

I have 3 Iris plugs…all 3 work via Smartthings, but only 1 works with Alexa. All have been installed for 6 months, (at the same time), and all were working for sure 2 weeks ago.

Have done the “disable”on Alexa, but doesn’t fix it. This is one of those “is it Alexa, or is it Smartthings”? Kind of hard to go “fiddle around” with Smartthing hub and devices when it appears to be working great!

Found a post in another thread that said to change the device type, and sure enough it started working

1 Like

How do you change the device? I don’t see anywhere to do that in the Alexa App.

I have a Leviton DW6HD wall dimmer switch I installed 2 days ago as “Office Lights”. It’s been working fine until this morning. Alexa says it’s unresponsive. The Leviton app turns it on/off fine. I’ve disabled the switch in Alexa and re-enabled it a couple of times. Still no joy.

Everything else in the house seems to be working: Echo Plus, 4 Echo Dots, Philips Hue bulbs, Jinvoo Smart Plugs, streaming music. This is my first Leviton smart device. Short of resetting the Echo Plus, I’m at a loss.

Any ideas will be appreciated.

What is DTH and where did you find it?

In the IDE go Into the device and edit the device handler

You change it by editing the device type by going to your IDE. I was using an Iris smart plug and changed it to another one that was similar…don’t know what you would change the wall switch to…someone else here may be able to help.

Thanks for the quick response.

I’m getting the gist here. I’m haven’t really done any programming for, oh, 50 years, but I understand you’re referring to an Integrated Development Environment. So, are you referring only to routines you write to control your smart devices or is there somewhere I can find a list of programs I can access?

Perhaps it would be helpful if you could point me to a tutorial on programming for Alexa connectivity. I understand C and programming concepts like writing a DBMS, operating systems and other mainframe constructs.

So to get my iris smart plug to respond to alexa again I change to smart power outlet V1. Seems to be back up and running now. I wonder what got changed as it worked fin for almost a year as it was