Alexa Australia has been released — now how to reconnect with smartthings?


(Texan069) #1

Woke up this morning to find Alexa has an Aussie accent. Typical of Australian technology, there’s a few things missing…like the smartthings app where all my devices are connected??? So if you have an alexa connected to smartthings here in “Fraggle Rock” you will only find apps that tell you the weather, a few jokes and probably thousand of other novelty apps but no smartthings app. I understand smartthings is not officially released in Aus but we have no option but to fiddle with things to get basic integration with the rest of the world’s toys. So up until this morning, my house has been automating just nicely with smartthings and Alexa.

Anyway, rant over but if anyone comes up with an idea on how to reconnect alexa with smartthings I’d love to hear it. It appears the issue is with the alexa app, amazon and language selection. Still working on it but it seems I may have to create a US account with amazon, set alexa back to US, install the smartthings skill and forget about the Aus options for ordering pizza and all the other companies that will eventually join alexa. So at this stage it looks like we are back where we started… set up and trick devices to appear as US.


(Paul) #2

Thanks for the heads up, I was going to update Alexa to the Aus settings when I got home but will hold off for now so I can keep control of my ST system. I can put up with her misunderstanding me every now and then!


(Texan069) #3

DEFINITELY DON’T!! It gets worse. I have created a new US amazon account behind a VPN and reset everything to no avail. So as of the 18/1/18 when the Australian Alexa update was injected into my devices, it effectively permanently disconnected from ST and the hundreds of dollars spent on “things”. Still have the ST automation side of it and turning shit of and on with my phone…but no voice control. It really shits me… we paid money to purchase these things to use as we see fit (the basis of ownership) and it really should be up to us if we run over it with a car or dare I say…use an app for an American product. Sorry for the rant but…really…what are they thinking.


(Tony Fleisher) #4

Are you able to use one of the community developed integrations (i.e. Ask Alexa or echoSistant)?


(Texan069) #5

I will have to look into to those options. I have contacted both Smartthings and Amazon Australia with my thoughts and concerns along with a request to include the Smartthings app in the skills for Alexa Aus. It shouldn’t be that hard so expecting a quick fix…lets see how this goes.


#6

Thanks for starting this thread.

I also tried to revert to my old US Amazon account to get SmartThings working, but to no available.

The only thing that Alexa (was) doing better than GoogleHome was FAST home control. If they dont fix it soon I will need to do 100% Google Minis.


(Texan069) #7

I have contacted both Amazon Australia and Smartthings. So far, I have had a quick response from both and expect further from Amazon on Monday. I also use Home Assistant and found that app is also not available as an Alexa skill. I hoping Amazon just simply add the skills we have all been using. Will post update on Amazon’s feedback.


(Texan069) #8

Encouraging news!! Just got off the phone with Amazon Aus who advised me all the Alexa skills will be available as of the 4th of Feb 18. Lets see how we go with ST and Home Assistant.


#9

I hope so. I got this message today Sunday 4th Feb:
"As the Echo services have not been fully launched for Australia yet, your skills will not work with the Australian settings.

You will have to deregister your Echo device from Alexa app and register it again with the US settings.

While completing the set up, change the language to English US instead of English Australia.

Once the device registered with the US settings, you will be able to use your skills as normal.

This should only be for a few weeks, as once we launch Echo and Alexa services for Australia, we will try to get most of the skills over due course of time."


(Texan069) #10

Yes I tried that process a couple of times now. Unless I’m missing something, it simply won’t revert back to US settings. Almost like they have made certain we can not use any US apps previously enjoyed before the Aus update. It makes no sense at all. Why update our devices with half the skills and disable choice of setup ??

To top it off, no update today. I have sent another email asking when the ST skill and HA skill will be available. I think you are right, might be time to start looking at Google Assist. Not sure if it will connect to ST but will start checking that out I think.


#12

Barry,
You will be happy to know, I just checked the Alexa app and SmartThings is back (enabled for Australia).

I didn’t have to change anything - all my devices came back,


(Texan069) #13

Great stuff Scott. I emailed amazon last week and asked them for instructions on how to revert back to USA settings. They actually provided me with a procedure to do it and that got me back online with ST. Just read your message, so I’ll look at going back to Aus settings now.

On a side note, I noticed that I now have the message symbol at the bottom of the alexa app. I can use alexa in the family room as an intercom for alexa in the bedroom. Do you seen the message icon at the bottom of the app with the Aus settings?

If anyone needs a procedure to change your amazon account to Australia, without having to create a new email, I’m happy to share what amazon provided me. Otherwise, I think the alexa and ST matter is Solved!


(Jason) #14

I don’t see the Smartthings skill in Alexa?
Do you see it?


#15

Hey Barry,
I dont have a special message symbol but it was asking me to setup “drop-in” but it wanted access to contacts so couldn’t be bothered. This might be linked to intercom functionality. As I only have one Alexa I can tell you if the intercom feature works.
Regards
Scott


#16

I do, it re-connected itself the other day.

You should be able to connect it yourself by going Smart Home > ‘Your Smart home skills’ > ‘Enable Smart Home Skills’

Should be under ‘popular’


(Texan069) #17

Thanks for checking Scott.

Unfortunately, I have changed back to Aus setting and the ST app does not come up in the search for me either. Anyway, back to US settings…


#18

Sorry to hear that. It is working for me. i.e. SmartThings under an Australian address.

My only complaint is I actually think the US setting may have understood my 3rd gen aussie accent better…

Maybe write back to them again and find out if the SmartThings release in AU was for everyone or just some users.


(Max Tay) #19

Also there is no household feature on your Amazon AU digital account which is a feature on Amazon US digital account. The household feature allows adding of second adult and hence voice recognition on Alexa. In short there are plenty of gaps for the Amazon AU digital roll out.


(Seamus) #20

Hi all,

Just curious, is this still the case (Smartthings not appearing in alexa). I have installed an Echo Dot but SmartThings isn’t available as a skill for me (obviously in Aus).

:frowning:


(Joel) #21

goodness. I just tested alexa like crazy - works awesome. but couldn’t add Australian news to my briefing so found my store in amazon was set to .com. changed it to .com.au and alas now i cannot use smartthings.