After reconnecting Smartthings in Google Home I can't get Zigbee RGBW Bulb to turn white with Google Home anymore

Yesterday I reconnected ST in Google Home to update to the new stuff. I can no longer get my ZigBee RGBW bulbs to turn to white or variations of white via the Google Home app. Other colors still work.

1 Like

Ditto.

Some Steps Ive tried and What I believe to be the root cause are in my post.

Tagging @Lars.

This is really weird, Ill look into it. Can you please give me the exact voice phrase you are telling Google? Eg “set kitchen light to soft white”

Yes, Soft white would be one of them. As mentioned in one of the other threads. The top Eight colors dont work even if you use the app ( Google Home ) directly . It seems to work, but then doesnt.
i,e White temperatures dont work. I dont know If a tunable white bulb would work in these situations.

It happens with the Google Home app too. It isn’t a voice specific issue. Started happening after doing the relinking Smartthings in the Google Home app to update to the new stuff.

I located the issue, will submit a fix immediately! Thanks for pointing it out. If anyone cares about the root cause it is that Google is using two different field names for color temperature to be backward compatible with and older version of their APIs. We updated to use the new name but didn’t realize they still kept the old name in certain conditions.

7 Likes

Whats the timeline for deployment?

Next Tuesday

2 Likes

Seems to be working now as of this afternoon.
Thanks.

Great, we expedited!