Aeotech Home Energy Meter (2nd Edition)


(evan) #1

I just purchased the Aeotech Home Energy Meter (2nd Edition) and I am not able to pair it with my Smartthings Hub (v1). I have read several posts regarding the need for a new device type, but it still doesn’t pair. I used (Aeon HEMv2+ written by Barry A. Burke). Can someone post the correct device type code as well as steps to get it operational. I appreciate any assistance in advance.

Thank you.


(sidjohn1) #2

If you can’t get it pared, the devicetype does not matter yet. Its highly possible the device is paired to another hub (from when it was tested), this is common for zwave devices. Use the link below to exclude it first, you should get a message that the exclusion is successful then try to pair it again. Once it’s paired you can change the devicetype if necessary. If you still have difficulties paring, try moving the device or hub closer together.


(evan) #3

Thanks sidjohn1 -
I was able to pair it this morning using a minimote by clicking on the include button on the remote and then double clicking the button on the back of the meter. It now shows up on my ST Hub, but nothing is being received from the meter. I have changed the device type (code) to the following:

However, the app is only showing place holders.

I’m kind of stumped now. I tried using the default ST Device Type (Aeon Home Energy Meter by SmartThings) by creating it from their template, but still no data.


(Eric) #4

a year ago, the color backgrounds caused “–” on Android platform only. Ipads and iphones would display correctly.

I think I’m also using Barry HEMv2+ device, I commented out all references to colors and then it mostly updates OK. (I’m usually on Android). There is a strange date “Since 2015/31/12/11:31” that I do not use.

The ST default device was for Aeon v1 hardware.