Aeotec Z-Wave Range Extender (for Danalock V3 Z-Wave) problems

I’ve got a Danalock V3 Z-Wave. It works fine when I’m physically nearby via Bluetooth and I was able to pair it to my v2 hub no problem, however, it essentially shows offline all the time. It’s about 40 feet from the hub with almost line of sight, but I figure maybe the angles just aren’t right so I got an extender. I installed the Aeotec Z-Wave Range Extender and paired it no problem. Unfortunately that didn’t help, so my question here is “how can I tell if the Aeotec is really working?” It shows up as an active device in the new app and my IDE, but I don’t know what to look for after that.

My net goal is to get the Danalock to work reliably.

Did you run the Z wave repair utility after you added the range extender to your network? Otherwise the devices that were already on the network won’t necessarily use it.

Also, how far is it from the lock?

When people suggest that you add a repeater to assist with a Z wave lock, they are not talking about increasing the range of the network. They are talking about adding a beaming device which can essentially act as an “answering service” for your lock and hold its messages until the lock wakes up again. That’s a different function.

See the community FAQ (the topic title is a clickable link)

Yup, repairing didn’t help.

I’m going to say it’s reasonable in this case that a repeater could be helpful for RF reasons (as opposed to message queuing). This is an open office situation with minimal RF interference, but enough distance that I had some trouble pairing Zigbee wall switches nearby. Once paired they are flawless though.

So that’s why my main question is “how can I tel if the repeater is getting used?”

Also, could this have anything to do with “secure mode” or whatever it’s called? My network is in legacy/normal/insecure mode. I’m just noodling that maybe locks prefer security for certain things? The lock shows up if I push the reset button or operate it manually, so that makes me think it has something to do with RF range and power- maybe the lock isn’t trying to communicate at full power except at certain times, and at lower power it can’t reach the hub?

Also could “device health” do anything? That’s active. I vaguely recall official support recommending killing that sometimes.

If the repeater shows up in your app, it’s being used. You don’t have to worry about that. There’s no on or off to it, if it’s on the network, it’s repeating.

I’m tired today, so I’m going to have to let other people answer your other questions.

@RBoy

K. I was hoping there’d be some way to see child devices / packets flowing through it, or something like that. Thanks for the tips- have a good day!!

Again I’m not sure if this is diagnostically useful, but I can only see the repeater in the new app, it is not showing in the classic one.

The repeater is maybe 25 feet from the hub (with good RF signal based on being able to pair and operate another device from the same plug, which was an intentional test) and about 15 feet from the lock (with great line of sight to the lock).

I think you’re mixing two different things. The link from @JDRoberts explains how a repeater helps and in the second post I’ve given some tips about the placement of the repeater w.r.t to having it act as a buffering device.

That aside, your issue is to do with the lock showing offline, the lock may actually not be offline. If you’re saying that when you operate it manually it shows offline, that means the locks is working fine. The offline health feature is complex to say the least, it depends on the DTH and other factors. If you’re able to operate the lock remotely when it “offline” then there’s nothing wrong with it. You can try using a different DTH or you can disable the Health Check feature from the Classic ST app.

During normal times, I cannot operate the lock via either ST app. The lock shows offline and acts unreachable (from ST).

If I manually operate the lock (by hand, physically twisting), then it begins to show in the ST app for a brief period of time (not sure how long, I haven’t timed it and I’m not there right now).

I could try different DTHs. I’m a paying customer of yours so I’ll have to see what I’ve bought. Maybe one of your lock DTHs is good?

Whoops- Health Check already was disabled.

That would indicate a communication problem, no DTH or health check will solve that issue. It’s a mesh or Z-wave chip issue.

You should try to exclude and re-pair your lock. If that still doesn’t work it may be a zwave module issue with the lock.

Fair enough. That’s pretty much what I thought before posting (that’s why I bought the repeater, duh).

Just to complete the thread here, it was a default Z-Wave Lock Without Codes and I just swapped that for Universal Z-Wave Lock With Alarms aka Universal Enhanced Z-Wave Lock (with alarms, RFID, door sensor and advanced features) (I realize this is unlikely to make anything better, but I’m not at the location and won’t be there again for a few weeks so I might as well just try whatever I can remotely!). It did not immediately solve any problems (again, duh).

Hello
Did you manage to resolve the issue?
I have the same problem with my danalock v3, Z-wave lock

Nope. I haven’t solved it yet, but Danalock issued an app update recently and they claimed it will help some stuff. They don’t have the best support but I think the underlying problem is something in their firmware and they’re working out the bugs… tbd. This is at a location I rarely visit, my next time is in a few weeks so I’ll try to mess with it when I’m there.

Thanks for your reply.
I’m confused. I’m thinking of replacing the lock with a new one (Zigbee instead of Z-wave)
I’m not sure if the problem will persist on zigbee version or this is a “bug” only for z-wave devices.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.