Aeotec Wallmote Quad

Hi all, I recently purchased a wallmote quad and have been unable to get it to work properly with my aeotec hub and smartthings. It shows up and is connected buy only 3 buttons are able to be controlled and only 2 types of controls are available for each button. I am fairly new to this stuff so I don’t know if I’m doing something wrong. I have reset it a few times and deleted and reconnected it. Still no joy. Any help would be greatly appreciated!

Edit the device in the IDE and double-check to ensure the “Type” is Aeotec Wallmote.


Thanks for the reply! Upon checking it does say that it is a aeotec wallmote. I reached out to aeotec supportt and they confirmed that they are seeing the same issue currently, at least for some of their employees.

1 Like

Is there an update? I have the same problem with only three buttons working. The first button works only randomly from time to time.

Lots of things have changed in the last year, including a major architecture overhaul by smartthings, so pretty much nothing above your post applies anymore. The IDE is no longer available and device type handlers are no longer used.

Instead, you need to get the custom edge Driver from Aeotec support. You can find their library at the following link:

Aeotec Edge Drivers : Aeotec Help Desk

To get the edge Driver downloaded to your own hub, just follow the link they list for their channel, subscribe, and then select the edge driver you want.

Once it is downloaded to your hub, you should be able to switch the wallmote to the new driver from the details page in the smartthings app. see the following FAQ:

FAQ: How to change to a different edge driver

If it still doesn’t work after you are using the correct edge driver, then contact Aeotec support since they are the authors.

Also, it sounds like you might find the first section of the following community FAQ helpful. It explains what edge drivers are and some of the basics of the new smartthings architecture.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

Good luck!